Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Re: Error when reloading document in QMC

Apparently the ReloadEngine has a problem with the pick() function or its parameters. I suggest replacing the stuff with chr(01) by some regular character like § (isn't used very often either) so that you can see where there is a missing replacement. I'm just guessing now, but I can't see those chr(01) characters either and the script clearly fails on something that shouldn't be there ("expecting a )").

Good luck,

Peter

Not applicable

Re: Error when reloading document in QMC

All, thanks for responses so far.  Peter, I will give your suggestion a try and report back. 

Highlighted
Not applicable

Re: Error when reloading document in QMC

Peter, thanks for your suggestion.  I tried what you suggested but that didnt work, however it got me thinking about characters in the tables.  It turns out that in my inline table , one of the fields contained an apostrophe. Taking this out made it run fine in QMC.  never really thought about that being an issue as it ran fine with the apostrophe outside of QMC.

Thanks again.

Duncan

Re: Error when reloading document in QMC

Mark your own answer as correct to close the discussion. The blue ballon in this discussion will turn green and that'll help people looking for answers.

Best,

Peter

sebastiandperei
Valued Contributor

Re: Error when reloading document in QMC

You also use $(Claim_Circumstances) in Preceding load, and the field you are reading is [Claim Circumstances].... If the script you have sent was the same you used in QMC or Local, i cant understand how it works.