Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Executing Batch File via Macro runs only once from Browser

Greetings Qlikview community!  Thank you in advance for taking the time to help out.

I have a macro defined that is currently associated with a Button:

sub testBatchFile

     Set WshShell = CreateObject("WScript.Shell")

     temp = WshShell.Run("C:\Test\test.bat", 0, true)

end sub

The contents of the Batch file (test.bat) are as such:

     echo test > C:\Test\test.txt

When I access the Qlikview document via a browser and click the button, the batch file successfully executes and the file test.txt is created.  However, subsequent clicks of the button does not cause the batch file to run.  (After the first successful run of the macro with the first click, I am deleting the file.  Subsequent clicks on the button does not produce a test.txt file)

Additionally, if I refresh the page or select filters, then clicking the button will execute the macro successfully.  However, subsequent clicks fail.

Allows System Access and Allow System Access are checked in Edit Module.  Under User Preferences -> Security -> Module and Script and Confirm Launch from Macro are all checked.

Thanks again for the help!

Community Browser