Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

paulyeo11
Valued Contributor II

Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

Hi All

I want to make 1 chart replace 2 chart by using diamension ?

Objective to save number of table and sheet or to reduce number of chart for my QV Doc.

Following is the step i did :-

STEP (1) Below is the script that declare the diamension :-

WhatIfDimension:

LOAD * INLINE [

     Pls select 66 Dim,Column51

  rEVENUE,rEVENUE

  nET_PROFIT,nET_PROFIT

  ];

STEP (2) After reload the script , i display field = Pls select 66 Dim on the sheet.

STEP (3) At the same time I set variable :-

I create new var = ColumnDim51

Defination as :-

=text('[' & (Column51) & ']')

STEP (4) I use the below script :-

Sum({<rEVENUE={"rEVENUE"}>}Amount)/1000

Modify it become as below :-

Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000

For chart 1 expression

My Question is why chart 1 does not display any bar ? where i go wrong on the above expression ?

As i except chart 1 display same as Chart A.

I will send my QV doc in my next post.

Paul

1 Solution

Accepted Solutions
paulyeo11
Valued Contributor II

Re: Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

I found the solution.

4 Replies
paulyeo11
Valued Contributor II

Re: Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

I found the solution.

Employee
Employee

Re: Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

Maybe you could share your information

paulyeo11
Valued Contributor II

Re: Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

Hi Clever

May i know why you are interested in the solution ?

money(

SUM({<year = {"$(=Max(year)-1)"},month={"<=$(=month)"},$(ColumnDim51)={$(ColumnDim51)}>}Amount*1)/1000

, $(vMoneyFormatK))

Above is the solution .

Paul

Employee
Employee

Re: Expression Sum({<$(ColumnDim51)={"$(ColumnDim51)"}>}Amount)/1000 not working

If someone else reach this discussion with similar problem, your solution could help he/she

Community Browser