Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Partner
Partner

Failed SQL connection after migration to new QV Server

hi

i need any help on this. I can run my QV documents, but i cannot access "views" and all tables from the databases i connect to. This is, i can run existing applications, but cannot use new tables on them.

We migrated QV from a machine to another one. Main facts:

1. QVS same version 11 SR2

2. I recreated in the new machine the data sources

3. After the migration, i addapted all QV documents and reload all of them. They worked

4. Usernames and passwords to access to my data sources are the same, before and after the migration (i still use the same rights)

5. Before the migration i could still access all tables and views i needed

6. After migration this is not possible.

7. We used in the first machine we have sql 2005 and in the second (new machine) SQL Server Client 10.

i do not know if the is may be a problem. We installed in the new machine updated software and did not want to use the same versions as in the old machine.

Do you have any other hints on this?

much appreciated

thanks

Felipe

1 Solution

Accepted Solutions
Partner
Partner

Re: Failed SQL connection after migration to new QV Server

thanks Vikas, this was already done and it was correct

I found the mistake, it was when creating the ODBC Source. I did not tick the box"Default Data Base" in the DSN Configuration. It seems that QV must have fixed the default DB when connecting to a data source (it is possible to also select the DB from a drop down list). When this was done, QV showed all schemas

thanks for your help

7 Replies
Highlighted
vikasmahajan
Esteemed Contributor

Re: Failed SQL connection after migration to new QV Server

Create ODBC for SYSTEM DSN I thing odbc connectivity can be missing in your case.

Vikas

Partner
Partner

Re: Failed SQL connection after migration to new QV Server

Hi thanks

i have created all DSN Data sources on odbcad32. I can see the data bases and connect to them. What i cannot see are all created objects in the database, which in QV are shown as "owner". I use SQL Server 2008 and can see dbo, info and sys objects but not other objects on the same database.

Before migration we accessed with SQL Server 2005, now with the SQL Server Client 10. I am not sure if this maybe a problem or if it is an authorization issue.

I checked all permissions at server and database level (also schema), and all seems to be correct. User was granted create_db permissions for the referred DB.

What settings should i consider under DB Security, so that when I connect in QV to that specific data base, i can see all created objects? Roles, user, schema, and what exactly?

thanks

felipe

vikasmahajan
Esteemed Contributor

Re: Failed SQL connection after migration to new QV Server

Open Sql Server -> login using Sa     

select  Database xyz -> security -> login -> user mapping -> tick database for that user

hope this will resolve your problem.

Vikas

Partner
Partner

Re: Failed SQL connection after migration to new QV Server

thanks vikas

i got those settings when i go on the server level (not specifically on a database level).

i checked the user mapping and the database for that user, to see if it is ticked and it is.

As said, i can connect to the database, but cannot see all owners. ex i see all

dbo.Table(X) tables, but not

qlik.Table(Y) tables

in Qlikview i see only the dbo, not the qlik owner (in the connection window). Most of the tables i need are located under the "qlik" owner.

any other ideas?

thanks

felipe

vikasmahajan
Esteemed Contributor

Re: Failed SQL connection after migration to new QV Server

Dear Sir,

Enter Qlik search for schemas you will find.

User Checking.JPG

Then map this schemas to your database this will resolve your problem.

Vikas

Partner
Partner

Re: Failed SQL connection after migration to new QV Server

thanks Vikas, this was already done and it was correct

I found the mistake, it was when creating the ODBC Source. I did not tick the box"Default Data Base" in the DSN Configuration. It seems that QV must have fixed the default DB when connecting to a data source (it is possible to also select the DB from a drop down list). When this was done, QV showed all schemas

thanks for your help

vikasmahajan
Esteemed Contributor

Re: Failed SQL connection after migration to new QV Server

Please close the post with assumed or correct ans so that other peoples can go thhorugh this types of

Scanario

Vikas