Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Field created by Partial loading not able to display value at table.

Hi All

I have read 3 sheet of excel raw data into QV. 2 sheet out of 3 sheet data is running fine , except 1 sheet data refuse to display at QV.

Only those field not able to display the 2 field which is created from partial load script. ( This is the first time i encounter this problem ).

At frist i though it is cause by i am not able to use :-

Price as LIST,

Price as LIST_PRICE

But i notice that even i use below command it still not able to display any value.

Subfield([Price],'USD',2) as LIST,

Subfield([Price],'USD',2) as LIST_PRICE

ROUND([Price],0.01)  as LIST_PRICE,

ROUND([Price],0.01)  as LIST

   

KeepChar([Price],'1234567890.') as [LIST_PRICE],

KeepChar([Price],'1234567890.') as

    I even try use the above command at partial load script , it still refuse to display result.

    and I even manually make the raw data number by manually type in the number it still refuse to display.

    Hope some one can share with me how to make those partial load script field display value.

    I have try for 3 hour , still unable to figure out why ?

    Paul

    1 Solution

    Accepted Solutions
    MVP & Luminary
    MVP & Luminary

    Re: Field created by Partial loading not able to display value at table.

    Hi Paul,

    You missed Concatenate keyword in COMPETE SERVO sheet in script, so add Concatenate before load statement in COMPETE SERVO sheet.

    Regards,

    Jagan.

    4 Replies
    Not applicable

    Re: Field created by Partial loading not able to display value at table.

    Hi Any one can help ?

    MVP & Luminary
    MVP & Luminary

    Re: Field created by Partial loading not able to display value at table.

    Hi Paul,

    You missed Concatenate keyword in COMPETE SERVO sheet in script, so add Concatenate before load statement in COMPETE SERVO sheet.

    Regards,

    Jagan.

    Not applicable

    Re: Field created by Partial loading not able to display value at table.

    Hi sir

    You are right. This drive me crazy. As I start to create this app from zero I found the problem. I should have look at data table model. Then i should find the answer. Any way it work now. 

    But binary load is good . It will still able work even I not pla a concatenated. 

    Sent from Samsung Mobile

    MVP & Luminary
    MVP & Luminary

    Re: Field created by Partial loading not able to display value at table.

    Hi Paul,

    Close this discussion.

    Regards,

    Jagan.