Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Field not found - <MaterialNo>

hi guys,

I able to connect  SAP R/3 system from Qlikview,

I key in query as like this to get  VRPMA SAP R/3 table data into qlikview,

VRPMA:

Load [MaterialNo],

     [SalesOrg];

SQL Select VRPMA~MATNR AS [MaterialNo] ,

           VRPMA~VKORG AS [SalesOrg]

           from VRPMA ;

but i am geting the following error,i am assuming some thing wrong with the above script.

Field not found - <MaterialNo>

SQL Select VRPMA~MATNR AS [MaterialNo] ,

           VRPMA~VKORG AS [SalesOrg]

           from VRPMA

can u let me know any one?

Rgds

1 Solution

Accepted Solutions

Re: Field not found - <MaterialNo>

Hi,

Did you try not using the table name (there is the only table you are pulling from SAP) or double quoting the name of the fields (the "~" may cause an error):

VRPMA: // without table name

LOAD MATNR AS [MaterialNo],

     VKORG AS [SalesOrg];

SQL SELECT MATNR VKORG FROM VRPMA;

VRPMA: // double quoting

LOAD "VRPMA~MATNR" AS [MaterialNo],

     "VRPMA~VKORG" AS [SalesOrg];

SQL SELECT VRPMA~MATNR VRPMA~VKORG FROM VRPMA;

Are you using the SAP Connector?

Hope that helps.

Miguel Angel Baeyens

BI Consultant

Comex Grupo Ibérica

9 Replies

Field not found - <MaterialNo>

Hi,

  Try this.

  

Load  VRPMA~MATNR AS  [MaterialNo],

     VRPMA~VKORG AS [SalesOrg];

SQL Select VRPMA~MATNR ,

           VRPMA~VKORG

           from VRPMA ;

   The reason of error is your load statement do not find the field MaterialNo.

Regards,

Kaushik Solanki  

Not applicable

Field not found - <MaterialNo>

hi Kaushik,thanking 4 ur reply...,but still have error..

Syntax error, missing/misplaced FROM:

VRPMA:

Load  VRPMA~MATNR AS  [MaterialNo],

      VRPMA~VKORG AS [SalesOrg]

VRPMA:

Load  VRPMA~MATNR AS  [MaterialNo],

      VRPMA~VKORG AS [SalesOrg]

Rgds

Field not found - <MaterialNo>

Hi,

   Yes cause you missed ; at the end of the load statement.

    It should be like this

   

VRPMA:

Load  VRPMA~MATNR AS  [MaterialNo],

      VRPMA~VKORG AS [SalesOrg];

SQL Select VRPMA~MATNR ,

           VRPMA~VKORG

           from VRPMA ;

Regards,

Kaushik Solanki

Not applicable

Field not found - <MaterialNo>

Kaushik, actually ; is thr in edit script ,when i copied the error msg from script execution progress display script error box,that ; not displyed,unfortunately i put that msg here...

but still have same error..

rgds

Field not found - <MaterialNo>

Hi,

   Can you please copy the script in txt file and then upload here.

Regards,

Kaushik Solanki

Re: Field not found - <MaterialNo>

Hi,

Did you try not using the table name (there is the only table you are pulling from SAP) or double quoting the name of the fields (the "~" may cause an error):

VRPMA: // without table name

LOAD MATNR AS [MaterialNo],

     VKORG AS [SalesOrg];

SQL SELECT MATNR VKORG FROM VRPMA;

VRPMA: // double quoting

LOAD "VRPMA~MATNR" AS [MaterialNo],

     "VRPMA~VKORG" AS [SalesOrg];

SQL SELECT VRPMA~MATNR VRPMA~VKORG FROM VRPMA;

Are you using the SAP Connector?

Hope that helps.

Miguel Angel Baeyens

BI Consultant

Comex Grupo Ibérica

Not applicable

Re: Field not found - <MaterialNo>

hi Miguel, ur absolutly right, after fetched 45,096 records i got this error msg again "

Field not found - <VRPMA~MATNR>

SQL SELECT VRPMA~MATNR VRPMA~VKORG FROM VRPMA

"

but fields are displaying in schema.

thanking you..

Re: Field not found - <MaterialNo>

Hi,

If you are not using the QlikView SAP Connector, then I'd bet for a driver issue, since fields are getting loaded properly (with some or alll the records in the database). Again, you can remove the table name and the "~" sign if all fields come from the same table, and hopefully you will not get any error.

Regards.

Miguel Angel Baeyens

BI Consultant

Comex Grupo Ibérica

Not applicable

Field not found - <MaterialNo>

Thanking u for ur inputs, yes i am using Qlikview Sap Connector.