Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

First 4 characters of some CSVs not being read

I've come back to Qlikview after a couple months away, hoping to get a few things done. Before I left, I had my load script working just fine. Now, I've got a weird problem: when I try to read some CSVs that live on a network share, QV does not read the first 4 characters.

The attached screenshot shows the csv, open in Excel, and what I see when I try to load the table with the File Wizard. Changing the delimiter to "Comma" fixes the delimitation problems, but doesn't make the first 4 characters of the file appear. Changing Quoting to "none" (which is how the file is written) doesn't help either, nor does changing the Character Set.

I'm getting a similar error when I try to read several other CSVs, many of which I haven't edited since 2013. Any guesses as to what's going on here?

If I move the file to my computer's desktop, it's read just fine.

Qv.png

Tags (1)
16 Replies
MVP & Luminary
MVP & Luminary

Re: First 4 characters of some CSVs not being read

Can you post your script?

Not applicable

Re: First 4 characters of some CSVs not being read

Sure thing. I've simplified for the sake of debugging, so all I've got in there right now is:

LOAD [County Name], FIPS, County

FROM

(txt, codepage is 1252, embedded labels, delimiter is ',', no quotes, header is 4);

That returns FIELD not found - <ACTIVITIES> even though....well, I'm pasting the first few lines of the csv below:

ACTIVITIES,Activities_Name

ATVCSV,ATV Campaign Steering Volunteer

ATVMCV,ATV Mucis Campaign Volunteer

ATVSCH,ATV Scholarship Campaign Volunteer

ATVSCV,ATV Science Campaign Volunteer

ADVB,Advisory Board

MVP & Luminary
MVP & Luminary

Re: First 4 characters of some CSVs not being read

I think there is a mismatch between your specified file-format and characterset and the data within your file. This could happens if you read an ansi-file with an utf-format which takes the first chars as BOM - reversely you get additionally chars.

I think the easiest way to get the right fileformat is to generate the load-statement new with the table-wizard.

- Marcus

Highlighted
payalgosar
Contributor II

Re: First 4 characters of some CSVs not being read

Can you create a new source file.

I had come across similar issue. I recreated the file and it sorted the issue.

Not applicable

Re: First 4 characters of some CSVs not being read

Well, it's not just this source file--it's about 15 others in the same directory. Considering that I'm not having any problems with Excel or my text editor reading them, I suspect the problem isn't in the files.

Too, some of these files are auto-generated, so recreating them because they won't load properly in QV isn't really an option.

Not applicable

Re: First 4 characters of some CSVs not being read

You'll notice in the screenshot in the original post, I run into exactly the same problem with the table wizard. I've tried all the default character sets in the "Character Set" drop down and none of them seem to make any difference (except Unicode which turns my file into Japanese ).

I also fiddled around with the Header Size: changing it to 4 Bytes doesn't make a difference. However, I lose MORE characters when I go up to 5 bytes.

MVP & Luminary
MVP & Luminary

Re: First 4 characters of some CSVs not being read

You need to use header lines and not header bytes.

- Marcus

Not applicable

Re: First 4 characters of some CSVs not being read

I tried that as well--using anything other than 0 header lines makes lines of my file start to disappear.

MVP & Luminary
MVP & Luminary

Re: First 4 characters of some CSVs not being read

Please provide an sample from your csv-file (a few records will be enough).

- Marcus