Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

General Script Error during STORE, but no locks on the QVD file

I am getting a "General Script Error" when executing a STORE command.  There are several questions about this on the community already, but they all seem to say that some other process must be locking the file or the directory does not exist.

I have checked with the native "Resource Monitor" app for windows and also the sysinternals Process Explorer and nothing seems to have an open handle on the QVD file I am trying to store.  We also disabled anti-virus thinking that might be causing a problem.  This is not the first file that is stored, so I know the directory exists and permissions seem to be ok since several other QVD files in that directory save successfully.  What else could be causing the problem?  The script fails on the same STORE command every time.  Any advice is greatly appreciated.  Thank you.

1 Solution

Accepted Solutions

Re: General Script Error during STORE, but no locks on the QVD file

I have seen this and it seems to me as if there needs to be a pause after the STORE, is use a Sleep(5000) to give 5 secong pause.  Your Left Join could give it the pause it needs.

14 Replies
Not applicable

Re: General Script Error during STORE, but no locks on the QVD file

I would also like to mention that this has been tried on two different servers and two different file paths on each server.  The General Script Error problem still exists for the same QVD file in all four cases.

vincent_ardiet
Contributor III

Re: General Script Error during STORE, but no locks on the QVD file

Hi Eric,

Nice mystery!

Have you tried to store only one row? We can imagine that there is a faulty row?

Or only one fied? If there is a faulty field.

Regards,

Vincent


Arjunarao
Honored Contributor II

Re: General Script Error during STORE, but no locks on the QVD file

Hi,

Close all the applications,folders,files and open the qvw again. Run it. It will works. Hope this will help you.

bunnyv123
Contributor

Re: General Script Error during STORE, but no locks on the QVD file

Hi Vincent ,

Can You please try partial load or qualify and UNqualify for an instance .

Check row and field .

Thanks ,

Bunny

Re: General Script Error during STORE, but no locks on the QVD file

Hi Eric,

Can you please share your script statements, that will give us a better idea 

nizamsha
Valued Contributor

Re: General Script Error during STORE, but no locks on the QVD file

Actually i cant get you what you are saying ,are you telling that you want to store  a qvd but you cant store as a qvd .is that my understanding is correct.

nizamsha
Valued Contributor

Re: General Script Error during STORE, but no locks on the QVD file

nizamsha
Valued Contributor

Re: General Script Error during STORE, but no locks on the QVD file

Hi

if its wrong mean Correct mean

1) Just want to confirm do u have a same Qvd in your Folder

2)it its so mean now its not allowing you store new qvd or existing qvd in that location

3)if its so check do u have access to that folder

4)if u don't have a access to that folder  that some one might have created from some other login ID but now u want to store in that same location

5)if its so mean give full rights to that folder read and right  permission from your  ID

6)Then check store command weather its working or not

7) as of me if this is the issue then it will work according to me

Nizam

MVP
MVP

Re: General Script Error during STORE, but no locks on the QVD file

Are you trying to overwrite an existing QVD? If so, try to delete/rename the QVD manually. Something is preventing QV from getting a write handle to the file.

Is there another task scheduled at the same time attempting to read from the QVD. This might put a transient lock on the file which would have disappeared by the time you looked. Does the error occur when you run the reload outside of the normal schedule (when nothing else is reloading).

Does the reload complete normally if you comment out the store? This is not the solution, I know, but try for diagnostic purposes.

Do you have an Exit Script statement followed by non-executed code. This code is still parsed and if a parse error occurs here, the script could still fail.

I suggest that you post or upload your script here, or at least the part that is failing.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Community Browser