Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

General script error

Hello everyone,

I am facing a curious problem. I hope someone will be able to help me.

I have server D which is my developement server.  When I want to put an application in production, I paste it in server S which is my "storage" server.  Then, the Qlikview server runs the application that are stored in server S.

I have an application which is store on server S. When I run it from server D, it works. But when I run it from Qlikview management console, it fails.

I have already have that case and each time, it was because I let some absolute paths instead of relative...

But this time it is not the case. 

this is the piece of code where the app fails :

STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

Drop table blabla;

This is what I've got in the journal after the application failed with QMC:

26/12/2014 21:34:26: 3375  STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd

26/12/2014 21:34:26:       General Script Error

26/12/2014 21:34:26:       Execution Failed

26/12/2014 21:34:27:      Execution finished.

So the application fails just before the drop table statement. But the QVD is stored (I've checked it).

Now I've tried to run it with one line in comment :

//STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

Drop table blabla;

or

STORE blabla into ..\QVD\QVD_PE\azer\blabla.qvd;

//Drop table blabla;

And in both cases, the reload works. It's only when there are these 2 statements that there is a failure.  I really don't get why...

Do you have any ideas ?

Please, do not hesitate to tell me if my problem is not clear..

Thank you for your help

7 Replies

Re: General script error

Hi,

Better way is if you store the Path into the variables and then use variable instead of relatives

Ex:-

Let vPath = Your QVD source location path here

And then in Store

STORE blabla into $(vPath)blabla.qvd;

Regards

Anand

neetha_p
Honored Contributor

Re: General script error

Hi,

Do you have any complex calculations or any incremental load in script?

Regards

Neetha

Not applicable

Re: General script error

jaja I like the blabla, sometimes I use Mickey or Pluto :-).

I feel that there is a problem with multi-threading internally in QlikView engine, but is it just a feeling. So, the next statement is trying to remove a table (blabla) while it is still being used by another working thread inside QlikView's kernel. just 2 cents. of opinion :-)

TRY as a test: load * inline  something after the store qvd statement and then drop blabla, so you will insert the load * inline code between both statements.

neetha_p
Honored Contributor

Re: General script error

Have you tried limit load and was it successful?

nagaiank
Valued Contributor III

Re: General script error

Did you try the following script?

STORE blabla into [..\QVD\QVD_PE\azer\blabla.qvd] (qvd);

prieper
Honored Contributor II

Re: General script error

Please check, whether the qvd, into which you wish to store, is not blocked (by previous QV-process) - helpwise you may change (temporarily) the name of this qvd.

Else you may check, whether you have an antivirus-program scanning/blocking your directory.

As Nagaian has written, specify the format (qvd)

Does you script really stop after the STORE-command? you may add an EXIT SCRIPT right behind.

HTH Peter

simone_spanio
Valued Contributor

Re: General script error

I'm quite agreed with Mario, try to delete blabla.qvd. If the system said that it is not possibile, then try to kll QV process and then retry to reload script.

Simon