Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Handling Special characters in xml data

Hi,

I am working on reading an xml file into my Qlikview App and the data contains special characters such as the ç and the registered trademark symbol.  When trying to load these values into the Qlikview App, I am getting a message of:

An invalid character was found in text content.

On line number: 26. On column number: 2070.

Is there a way of handling these special characters when reading data from an xml file?

Thanks

Tags (2)
6 Replies
Not applicable

Re: Handling Special characters in xml data

Hi Nielsh,

I have the same type of problem when I am reading the xml code from a qvd.

Did you got any responce yet??

Regards,

Not applicable

Re: Handling Special characters in xml data

Try with ASCII no instead of special character.

Not applicable

Re: Handling Special characters in xml data

Yes, but how can track down which special character causes the issue???

richard
Contributor

Re: Handling Special characters in xml data

Not applicable

Re: Handling Special characters in xml data

Hi Nikos,

The only way I could get Qlikview to read the file was by changing the character set from utf-8 to windows-1252 in the xml file.  It looks like some of the characters which were in the xml file were not utf-8 compliant.

Thanks

Nilesh

Employee
Employee

Re: Handling Special characters in xml data

Please assure that is the first line of your xml

<?xml version='1.0' encoding='UTF-8'?>

Community Browser