Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

How to read Excel files from Sharepoint

Hi All,

I am trying to load files put in sharepoint folder in Qlikview. But I am getting "Bad Zip File" error.

I had opened the folder in sharepoint using "Open with Explorer" option and copied the link of it and used it to load in Qlikview Table.

I tried removing the https from the link but then it throws "Network not found error".

I tried many options mentioned in this community. But still am failing.

Please provide a solution...

Tags (1)
3 Replies
john_s_w_wood
Contributor

Re: How to read Excel files from Sharepoint

Hi

I had a similar issue. Fine from Desktop but wouldnt work from AccessPoint. The solution was to look at something like QVSource who have a Sharepoint connector (OData).

john_s_w_wood
Contributor

Re: How to read Excel files from Sharepoint

Actually this may have been more to do with sharepoint lists. May be worth a chat to QVSource though.

linusblomberg
Contributor II

Re: How to read Excel files from Sharepoint

I was trying to accomplish this at my old firm. unfortunately I no longer have the files (or sharepoint to test) but mybe I can be of help anyway.

There are several issues connected to this.

First you need to find the real URL to where the files are located. this differs on the version of SP. I got this working using my desktop version since me as a user was logged in to sharepoint. When you find out the URL just connect as any webfile.

Second and this is what I didn't manage to solve before I left. Sharepoint has some sort of authentication method which qlikview has support for (at least Sense). But it is tricky.  I was told that this would be manageble using a manual reload button in the qlikview app. You need to be logged in on sharepoint on the server OS running as your own user. There is support this this as I said. Anyway I can barely remember. Basically this is a Sharepoint problem not a qlikview problem.

hope I could at least point you in the right direction

Community Browser