Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
xufei123
Valued Contributor

How to turn off prj?

Hello, we do not want the prj folders to be automatically created. Where can I set it off? I have checked the document property and user preferences but could not find the trigger.

Thanks.

Tags (1)
1 Solution

Accepted Solutions
xufei123
Valued Contributor

Re: Re: How to turn off prj?

Hi Andrea,

I have created a ticket and QlikTech has answered that for me as following:

The current issue was identified as bug. Here are alternate solutions to overcome the issue for now.

1. After creating qvw document, please select SAVE option, instead SAVE AS.

or

2. After saving a qvw document, using 'SAVE AS' selection, then rename the document and it opens without
issue.

So basically my colleague always press F12 to SAVE the file AS some name and I always use SAVE. So we have different results.

6 Replies
Not applicable

Re: How to turn off prj?

Hi

I could be wrong here but I am pretty sure that there is no "setting" that makes the PRJ folder create automatically, this is manual, so you can either create the PRJ folder in the directory where the QVW exists, or not create it.

If the PRJ folder exists, you cannot have one QVW document creating XML versions of its objects, and another QVW document not creating them, the fact that the PRJ folder exists means that all QVW's in that folder will create XML files.

So, short answer to your question is, delete the PRJ folder.

xufei123
Valued Contributor

Re: How to turn off prj?

Hi Nigel,


Thank you very much for your reply.

It sounds impossible but I have tried in two directories. I deleted all
the prj folders, it works for one directory where even I create a new qvw file,
reload and save, the prj folder does not come out any more. While for the other
directory, I do the exactly same thing, prj folder is still automatically
created.

Fei

agigliotti
Honored Contributor II

Re: How to turn off prj?

Hi Fei,

I have the same problem, did you solve it?

Thanks and Best Regards

Andrea

xufei123
Valued Contributor

Re: Re: How to turn off prj?

Hi Andrea,

I have created a ticket and QlikTech has answered that for me as following:

The current issue was identified as bug. Here are alternate solutions to overcome the issue for now.

1. After creating qvw document, please select SAVE option, instead SAVE AS.

or

2. After saving a qvw document, using 'SAVE AS' selection, then rename the document and it opens without
issue.

So basically my colleague always press F12 to SAVE the file AS some name and I always use SAVE. So we have different results.

agigliotti
Honored Contributor II

Re: Re: How to turn off prj?

Hi Fei,

Take a look at settings.ini file and search for [Settings 7] section, there you should add or modify the parameter name CreateProjectFolder = 0.

Best Regards

Andrea

Luminary
Luminary

Re: How to turn off prj?

Thanks Fei. Which version and build are you referring to?

Cheers,

DV

Community Browser