Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

I cannot get the table viewer to connect with the data

I am not sure how to describe my issue.  I need the Key and Key-2 to connect with the Data and I don't know how to do it.  Please help!

1 Solution

Accepted Solutions

Re: I cannot get the table viewer to connect with the data

In your Table Viewer screenshot, note that Question and Employee G... link to the corresponding fields in the Data table. That is because their names are exactly the same (including identical spelling and case) as those in the Data table. This equality causes QlikView to auto link these fields by default.

To make the two other key fields link as well, change their names so that they match those of the corresponding fields in the Data table (Functional ... and Length of E...).

Unfortunately I can not tell you what is wrong with those two names, as your screenshot doesn't show the entire name of each key field.

In Table viewer, drag the right table border of both Key, Key-2 and Data to the right so that we can see the correct names. Then post a new screenshot.

To rename a field, you can use a column rename with keyword 'AS' in the LOAD statement  For a full explanation, see the QV Desktop help article for the LOAD statement. Here's an example:

LOAD Field1 AS ID,

     Field2 AS Name,

     field3 AS City

FROM data4.fix (ansi, fix, no labels, header is 0, record is 80);

Best,

Peter

11 Replies
miguelbraga
Valued Contributor III

Re: I cannot get the table viewer to connect with the data

Hi there,

Use this:

left join (Data)

Key-1:

...

left join (Data)

Key-3:

...

Regards,

MB

Not applicable

Re: I cannot get the table viewer to connect with the data

Thank you for your assistance.  I am very perplexed by Qlikview and do not have programming experience.  Would you please break down the steps involved in your suggestion?

Re: I cannot get the table viewer to connect with the data

In your Table Viewer screenshot, note that Question and Employee G... link to the corresponding fields in the Data table. That is because their names are exactly the same (including identical spelling and case) as those in the Data table. This equality causes QlikView to auto link these fields by default.

To make the two other key fields link as well, change their names so that they match those of the corresponding fields in the Data table (Functional ... and Length of E...).

Unfortunately I can not tell you what is wrong with those two names, as your screenshot doesn't show the entire name of each key field.

In Table viewer, drag the right table border of both Key, Key-2 and Data to the right so that we can see the correct names. Then post a new screenshot.

To rename a field, you can use a column rename with keyword 'AS' in the LOAD statement  For a full explanation, see the QV Desktop help article for the LOAD statement. Here's an example:

LOAD Field1 AS ID,

     Field2 AS Name,

     field3 AS City

FROM data4.fix (ansi, fix, no labels, header is 0, record is 80);

Best,

Peter

Not applicable

Re: I cannot get the table viewer to connect with the data

Re: I cannot get the table viewer to connect with the data

I think you may have given the xxxx Number names to the fields that contain the text values.

In Table Viewer, right-click on table Key and select Preview. Have a look at the values that are stored in column Functional Group Number.

Peter

Re: I cannot get the table viewer to connect with the data

Ow, I was too slow with my last reply. Did you fix it?

Not applicable

Re: I cannot get the table viewer to connect with the data

Got it, thank you so much.  So I think I want the Mean for Employee Group, Functional Group and Length of Employment to actually be like the questions and I cannot tell what I have done wrong in the properties to make it different.  Can you help me with that?

Re: I cannot get the table viewer to connect with the data

That's a bit hard to figure out from the images alone (and without a lot of tedious questions). Can you post an example document in this thread?

Best,

Peter

Not applicable

Re: I cannot get the table viewer to connect with the data

Never mind about that request.  I don't want that actually. What I do want is an accurate count of who is in each group; Functional, Employee, and Length of Employment.  It looks like the counts are good on the Functional and Length of Employment Groups, but the Employee Group is super off.  We only had 315 responses.  Come to think of it the Questions are not accurate either...perplexed again.  It may have to do with my spreadsheet but I set everything up exactly like a previous version from another year and another author.

As you can see the Director went from 8 on the previous picture to the now 664.  Yikes!

Community Browser