Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

If Statement not showing correctly but has no error

Hi,

I have the below statement that shows without error, but is only giving 1 scenario instead of both.

Please assist

=if(Closed_Date =' ' AND [Sbu_Desc]='UNKNOWN'

  ,'Complaint In Progress',

'Known')

1 Solution

Accepted Solutions

Re: If Statement not showing correctly but has no error

Hi,

Sorry my mistake.

If(Isnull(Closed_Date) and Wildmatch(Sbu_Desc, 'UNKNOWN'),'Complaint in Progress','Known')


Try this.


6 Replies

Re: If Statement not showing correctly but has no error

Hi,

You can try this.

If(Isnull(Closed_Date) and Wildmatch(Sbu_Desc = 'UNKNOWN'),'Complaint in Progress','Known')

Regards,

Kaushik Solanki

Not applicable

Re: If Statement not showing correctly but has no error

Thanks but its giving me an error in expression and no result

Re: If Statement not showing correctly but has no error

Make sure that you have put correct name of the fields.

The expression it self will show where is the mistake by red line.

Regards,

Kaushik Solanki

Not applicable

Re: If Statement not showing correctly but has no error

Its showing a red line at the bracket and comma between UNKNOWN and Complaint in Progress.

'UNKNOWN'),'Complaint in Progress

Re: If Statement not showing correctly but has no error

Hi,

Sorry my mistake.

If(Isnull(Closed_Date) and Wildmatch(Sbu_Desc, 'UNKNOWN'),'Complaint in Progress','Known')


Try this.


Not applicable

Re: If Statement not showing correctly but has no error

Its working!

Thank you sooooo much :-)

Community Browser