Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

New Contributor

Incomplete CSV load

I have a csv file that contains ~300,000 full rows of data. When I load this file in qlikview, it only extracts ~37,000 and finishes. There are no error messages and no obvious reasons why it would end here. Other files of the same format etc have loaded without a problem. Does anyone have any ideas what could possibly be causing this?

Many Thanks


5 Replies
Contributor III

Re: Incomplete CSV load

can u upload csv file

Valued Contributor II

Re: Incomplete CSV load

If it fails at the same point every time, you probably have a hidden control character in your file.  These can be particularly hard to spot but often occur in free text fields where a user has copied and pasted text from (eg) an email or word document in the front end.


Re: Incomplete CSV load

Most likely cause is an unexpected character. This can happen when the file was created with utf-8 and in qlikview the character set Western European is choosen. Or vice versa. Try changing the character set used to read the data.

(txt, codepage is 1252, embedded label, delimiter is ',', msq);

(txt, utf8, embedded labels, delimiter is ',', msq);

talk is cheap, supply exceeds demand
New Contributor

Re: Incomplete CSV load

Hi, thanks for the advice. I've tried it using both encoding options but get the same result. It doesn't stop at a particular point in the file, it seems to choose specific records to load and omit others. It's the same records every time but there's nothing in particular that distinguishes these and there is no 'where clause' included in the script. Some files in the same format are loaded without a problem. Could this still be caused by control characters..?



Not applicable

Re: Re: Incomplete CSV load

Hello G Wassenaar,

I am interested in this thread except on ‘csv download’ instead of ‘incomplete csv load’. 

A user chooses to send her report to Excel, then experiences a csv download instead of Excel. She then has to re-format invalid name errors.  A consultant stated it's due to the size of the file; I beg to differ because the file is fewer than 6MB.

You stated to Darren the "most likely cause is an unexpected character."  I wonder if my issue is because the 'customer name' field sometimes begins with '+++' which is a visual cue (no matter how poorly chosen) indicating a retired customer account.  On the other hand, I am able to download the same report successfully on one attempt and unsuccessfully on another attempt; where the good result was downloaded with data not expanded and the bad result was downloaded with data expanded.  Again, the file is no more than 6MB.

The good result is filename "not expanded.xlsx."  The poor results are filenames "expanded.txt" and "expanded.xlsx".

I was not able to identify if there is a Presentation setting that allows only Excel when a user chooses that command.  Can you help? Thank you in advance.

Kind regards,


Community Browser