Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Incremental load where criteria on QVD not working?

Hi All

I'm trying to do an incremental load that is based on a date field but when I come to load in the QVD and concatenate to the incremental load my where condition wont work, it just gives me the same 4 records as incremental load? I've tried reversing the greater than symbol (though that doesn't seem to make sense) but this just loads everything. Here's the code:

concatenate(List) LOAD "AC_ACCOUNT",
"CS_COST_CENTRE",
"GL_TRANSACTION_TYPE",
"GL_BATCH_REF",
"GL_DESC",
"GL_AMT",
"PD_PERIOD",
"GL_ANALYSIS_1_ID",
"GL_VOL",
"GL_REF",
"SLT_OUR_REF_2",
"SLT_THEIR_REF",
"NA_CODE",
"NA_NAME",
"PD_YEAR",
"GL_SUB_LEDGER",
"GL_POSTING_SYSDATE"
FROM
List.qvd
(qvd)
where (not GL_POSTING_SYSDATE>$(MAXGL_POSTING_SYSDATE_2));

Please can anyone advise what I'm doing wrong?

Thanks

Dominic

1 Solution

Accepted Solutions
Not applicable

Incremental load where criteria on QVD not working?

changed the where to GL_POSTING_SYSDATE<'$(MAX_GL_POSTING_SYSDATE_2)';

I had tried this before but without the single quotes around the variable! aaaarrrgh!!

But at least it works now Smile

3 Replies
maneshkhottcpl
Contributor III

Incremental load where criteria on QVD not working?

Hi,

Can u please check the Date formate of both date. Whenever using the varible its convert into number i.e $(MAXGL_POSTING_SYSDATE_2)); will return the numeric value . write like date($(MAXGL_POSTING_SYSDATE_2). or sent me ur application with 10 row load.

Good Luck Smiley Happy

Not applicable

Incremental load where criteria on QVD not working?

Hi The varable gets defined like:

LET MAXGL_POSTING_SYSDATE_2 = date(peek('MAXGL_POSTING_SYSDATE',0,'maxtimes'),'DD/MM/YYYY');


so is a date format?

Thanks

Not applicable

Incremental load where criteria on QVD not working?

changed the where to GL_POSTING_SYSDATE<'$(MAX_GL_POSTING_SYSDATE_2)';

I had tried this before but without the single quotes around the variable! aaaarrrgh!!

But at least it works now Smile

Community Browser