Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
datanibbler
Esteemed Contributor

JOIN problem - is there anything with table_names?


Hi,

just curious: I just had a very strange phenomenon:

- I had in my DataModel a table >> Transaction_aux2 << and a table >> Personal_WE <<

- I wanted to join those on three fields - week, shift and a box_number, to do several things:

  => To filter the table >> Transaction_aux2 << to only the records that could be matched with the other table

  => To get from the other table one more field

<=> For some reason, it wouldn't work. I tried several times, checked the table_names and the fields, copied them to rule out

       typos - the errror was >> Table not found << when I loaded the fields from that >> Personal_WE <<

<=> In the end, I renamed - the other one, the >> Transaction_aux2 << - and then it worked.

Is there any particularity with JOINs about the table_names (except they have to be correct)?

Thanks a lot!

Best regards,

DataNibbler

Tags (1)
Community Browser