Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

JOIN

HI,

I need to connect the tables using join

What is the correct way to do it?

The Table in the cloud shows wrong data and blanks.

6 Replies
Not applicable

Re: JOIN

Thanks for your response, but it does not work well.

All tables should be linked somehow with'' the keys, join etc.. I do not really know how

Not applicable

Re: JOIN

Hi,

Did you notice that in the table customer, the customers 19, 63, 72 and 77 have no country code.

This is a reason why you see 'blanks' in your chart.

And!  CustomerID that you use in your chart is defined in 2 different tabels, in Sales and in Customers.

QlikView does not now that you want only records form your table Sales.

Load additional field in table Sales: CustomerID as SalesCustomerID.

Then replace in your chart CustomerID by SalesCustomerID.

Regards,

Gerrit

Not applicable

Re: JOIN

Category name column and product name there are some 'blanks (in the Bottom of the table)

Not applicable

Re: JOIN

Category name column and product name there are some 'blanks (in the Bottom of the table)

Even if I do what you recommended

Not applicable

Re: JOIN

Hi,

If you did this:

Load additional field in table Sales: CustomerID as SalesCustomerID.

Then replace in your chart CustomerID by SalesCustomerID.


As far as I can see you should be ok.


Maybe have look here: Extract, Transform, and Load

Regards,

Gerrit

javier_florian
Contributor III

Re: JOIN

Hi Alon,

I reviewed your qvw file and that is correct, you can see your model like this:

You and only you know your own model, but I recommend you the follow post:

Understanding Join, Keep and Concatenate

An additional recommendation, in Sales tab you load Sales.xls and SalesHistory.xls, you can invoke an only script like Sales*.xls

-Javier Florian

Community Browser