Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

SAgl
New Contributor II

Left join doesn't join rows even relation is one to one

Hi All, 

I'm working with version 12.0.20001.0 SR1 64-bit Edition (x64) with data stored in QVDs extracted from Mysql.

I have a fact table where every sevice we sell to our clients is stored by client number  and I need to join the clients information to it by joining the clients catalog but i notice that even the relation on both tables is 1 to 1 qlikview only shows the infromation for 4 clients and it doesn't show it for the rest 13,000.

Can someone help me?

1 Solution

Accepted Solutions
SAgl
New Contributor II

Re: Left join doesn't join rows even relation is one to one

Hi, thank you for your answer, i removed spaces and change number format already, i noticed is a bug in version 12.1 SR1

View solution in original post

2 Replies
Highlighted
olivetwist
Contributor

Re: Left join doesn't join rows even relation is one to one

Is there a reason you need to join the client info to the fact table? Can you not use two separate table linked by client number? it is generally a resource savings. That aside, my best guess is that the format of the client number is different in each source. Maybe loosing leading zeros or you need to trim extra spaces. Something like that. Without seeing the data, i can't say why they aren't joining.

SAgl
New Contributor II

Re: Left join doesn't join rows even relation is one to one

Hi, thank you for your answer, i removed spaces and change number format already, i noticed is a bug in version 12.1 SR1

View solution in original post