Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
hansrokers
New Contributor II

Load from hidden shares does not work anymore

I have just installed the latest version (QV 12.20)

A lot of my documents now fails to reload.

The problem is the $ in the filename (hidden share).

This used to work:

LOAD @1

FROM

[\\myserver\nfs$\edi\abc*.txt]

(txt, codepage is 1252, no labels, delimiter is '|', no quotes);

Now it results in: Unknown LOAD statment error.

Is there a reason that this does not work anymore or a bug ?

9 Replies

Re: Load from hidden shares does not work anymore

Could you try it without the $-sign? I'm not sure if it's not just a measure from windows to hide them within the explorer but that they could be furthermore directly accessed.

- Marcus

hansrokers
New Contributor II

Re: Load from hidden shares does not work anymore

It does not work without the $-sign.

It even does not work when I map the unc-path to a drive letter.

Re: Load from hidden shares does not work anymore

Did something else change, too like an upgraded OS or anything to the access-rights of this folder/files or the server-name or ...?

Did you try it with a removing of the $ and the hidden state - just to check that the path itself will working.

- Marcus

hansrokers
New Contributor II

Re: Load from hidden shares does not work anymore

The only thing changed was the installation of 12.20.
I have now re-installed version 11.20 and it is working again.

jerrysvensson
Valued Contributor II

Re: Load from hidden shares does not work anymore

Which SR of 12.20 do you have?

Tried SR5 and it worked.

Re: Load from hidden shares does not work anymore

AFAIK, at the moment there is only an IR available of v12.20. But the IR of every Qlik product often has a bug or two

jerrysvensson
Valued Contributor II

Re: Load from hidden shares does not work anymore

Haha

My mistake.

12.0 SR5

jszczesniak
New Contributor

Re: Load from hidden shares does not work anymore

I have a very similar problem also.  I have an upgraded copy of our version 11 box with 12.20 SR3 installed and the FTP extractor does not work on the upgraded version.

LogisticsChg:
LOAD *
FROM
[ftp://SVCAcctSmiley TongueW@SAPServer.ent.textron.com/interfaces/SD/out/bel/Logistics_Chg_JAN-JUNE_2018.csvPW@SAPServer.ent.textron.com/interfaces/SD/out/bel/Logistics_Chg_JAN-JUNE_2018.csv]
(
txt, codepage is 1252, embedded labels, delimiter is ',', msq);

It gets this error on V12 but works on V11

Error: Unknown LOAD statment error

hansrokers
New Contributor II

Re: Load from hidden shares does not work anymore

This bug still has not been fixed.

Anyone found a work around ?

Community Browser