Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Microsoft script debugger not found on system

I'm trying to debug some module code. But in the Edit Module window, clicking on the Debug button brings up a dialog that says "Microsoft script debugger not found on system". I installed the Microsoft Script Debugger but still get this problem.

I am running QlikView Version 9.00.7119.4 64-bit Edition on Microsoft Windows XP Professional x64 Edition, Version 2003, Service Pack 2.

I got the script debugger from this Microsoft download site (titled "Script Debugger for Windows NT 4.0 and Later"): http://www.microsoft.com/downloads/details.aspx?familyid=2f465be0-94fd-4569-b3c4-dffdf19ccd99&displa...

I installed the debugger into both the "C:\Program Files (x86)\Microsoft Script Debugger" directory (the default) and "C:\Program Files\Microsoft Script Debugger". I even restarted after installing.

On my 32-bit machine, I am able to run the module debugger, even thought I never manually installed the Microsoft Script Debugger.

Joe

10 Replies
Not applicable

Microsoft script debugger not found on system

Try installing Microsoft Visual Studio 2005/2008.

Microsoft script debugger not found on system

That's an older debugger that doesn't work well with XP. As previously suggested, you can get the newer debugger by installing Visual Studio -- or MS Office.

-Rob

Not applicable

Microsoft script debugger not found on system

The same problem happens on my computer.

I have Windows 7 Pro 64-bit, installed QV Version 9.00.7257.6 SR1 64-bit, and see the same message of "Microsoft script debugger not found on system".

I have installed Dev Studio 2008, Script Debugger for Windows NT 4.0 and later, and even Internet Explorer Developer Toolbar. Same message.

Does any one have any suggestions? I'd hate to spend $150 or more on Microsoft Office just to debug my QlikView scripts. I suspect that QlikView 64-bit isn't compatible with Windows 7 or XP 64-bit.

- Matt

biester
Valued Contributor

Microsoft script debugger not found on system

I've the same issue on 64 bit with MS script debugger. I need to debug on the server and I want to keep my server clean, without Office and Visual Studio. But I've already a support call running also concerning this issue.

Rgds,
Joachim

Not applicable

Microsoft script debugger not found on system

Just to keep this thread alive, I am running into the same problem. Windows 7 64bit Enterprise, Visual Studio 2010 Premium, QlikView x64 SR2. If I use 32bit QlikView the debugger seems to work. No dice when running the 64 bit version. If I had to venture a guess, I figure it's looking for the debugger DLL to load it, but as it doesn't live in SysWOW64, it doesn't find it. (not to mention that 64bit dll's have different module entry points, so a 32bit one wouldn't work anyway). Script debugging works fine in IE8 64bit.

What gives, QlikTech?

Not applicable

Microsoft script debugger not found on system

Another input here;

I'm running into the same problem with QV 64-bit (ie no debugger found).
On the very same machine I also have QV 32-bit installed and there the debugger works just fine.

Same QV document, same computer, only difference is 32/64 bit. Something's fishy here.

/Mattias

claus_strouhal
New Contributor II

Microsoft script debugger not found on system

Same problem, anyone opened an support ticket on this problem ?

Seems we need a bugifx asap

/Claus

Not applicable

Microsoft script debugger not found on system

Anyone?

Not applicable

Microsoft script debugger not found on system

Ditto. I have QV 9.0 SR5, running on Win 7 x64. I have the full Visual Studio 2008 installed and Office 2007 SP2.

I assume this is a path issue, the QV client can't find my debugger so I hoped this is something I could fix but this thread makes me think nobody has figured it out yet. Bummer.

Community Browser