Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

OLEDB CONNECT Hangs on server

Hello,

I have this weird problem on OLEDB CONNECT. I'm using the classing connection string:

     OLEDB CONNECT TO [Provider=OraOLEDB.Oracle.1;Password=<clear password>;Persist Security Info=True;User ID=<clear user id>;Data Source=<IP address>:1521/ORCL;Extended Properties=""];

Using it from QV Desktop the connection is done but when using it from QV server the task remains "Running" indefinitely and on the logs it is possible to see that the script is waiting something on command"OLEDB CONNECT ...".  No errors are seen until I abort the task.

I checked that the Oracle OLE DB provider is working correctly (on both: 32 an 64 bits).

Have you some tips to help me understand what is going on?

There are some way to "debug" tasks when running on server?

Thanks in advance,

Luciano.

2 Replies
kmswetha
Contributor

Re: OLEDB CONNECT Hangs on server

In server as well, TNS entries should be made.Try adding TNS entries.

Not applicable

Re: OLEDB CONNECT Hangs on server

Hello,

the TNS entry exists, but I'm not using it on OLEDB Provider. I'm using the <IP address>:1521/ORCL syntax (on desktop works and I see it working on other QV Server). There are no firewall issues as I tested the same kind of conection with the following VB script:

Dim Conn

Set Conn = CreateObject("ADODB.Connection")

Conn.ConnectionString = "Provider=OraOLEDB.Oracle.1;Password=<clear password>;Persist Security Info=True;User ID=<clear user id>;Data Source=<IP address>:1521/ORCL"

Conn.Open

Set RS = Conn.Execute("SELECT * from DUAL")

...



Thanks,

Luciano.