Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
jitiong90
New Contributor III

PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi all,

I am having problem in loading a text file by using "fixed record" as the file type, I am able to load the data without getting any error.

However, problem comes up when I apply "enable transformation steps" at the same time, the system shows the "field not found" error when I apply

"enable transformation steps" while loading the data by using "fixed record" as the file type.

Anyone has solution for this issue?

Please find the attached for my script and sample text file.

Thanks.

9 Replies
Not applicable

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi,

I have tried uploading your file as "fixed record" and enabled transformation steps. I didn't had an error. Could you attach some screenshots of the error?

Regards,

Janzen

jitiong90
New Contributor III

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi Janzen,

Thanks for your effort to try.

Below is the screenshot of the error that I got.

error1.JPG

Thanks,

Tiong

Not applicable

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi,

May I ask where did you get this line?

"filters(Remove(Row, Pos(Top,2)))"

Did you add any steps after setting header to 2 lines?

Regards,

Janzen

jitiong90
New Contributor III

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi,

Yes, after setting header to 2 lines, I clicked next button and enabled the transformation steps from the page as the screenshot shown below, thats where I got the line "filters(Remove(Row, Pos(Top,2)))".

2.JPG

Thanks,

Tiong

Not applicable

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi,

After clicking Enable Transformation Steps, what did you do next? If you dont need to transform, you can just click next to proceed.

Regards,

Janzen

jitiong90
New Contributor III

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi,

Yes, I did some transformation steps to remove the row with "+++++++" characters, but it is so much more complicated in actual situation so I cannot avoid using transformation steps.

Thanks,

Tiong

Not applicable

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Did you found a solution? I've the exactly same problem.

jitiong90
New Contributor III

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi Shellmann,

No I haven't, I did it with a workaround which I load the data first by using "Fixed Record" and store the table into qvd and then I load the data back from the qvd and perform the transformation step there.

Not applicable

Re: PROBLEM: Loading by using "Fixed Record" and "Enable Transformation Step"

Hi Jitiong Chua,

I'm having the same issue.  I'll try the QVD intermediary step.  Thanks for suggesting that.

Regards,

DJ

Community Browser