Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
Talk to Experts Tuesday, Live Q&A, September 22: Moving from QlikView to Qlik Sense. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Creator
Creator

Prblem in Set Analysis logic

Hi,

I am new to Qlikview and facing strange issue with small set analysis expression

This is my expression

SUM({<[Campaign Channel]={'PPC'}>}[Site Visit Vis Num])


Actually there is data for campaign channel and as well for Site Visit Vis Num as I checked individually.

If I combine as expression it is returning '0' for all dates.

Can anybody help me how to resolve this issue. Thanks in advance

Regards,

Kumar

30 Replies
Highlighted
Not applicable

Mate,

Can you please try this: its just a test.

SUM({$<[Campaign Channel]={"PPC*"}>} if(isnull([Site Visit Vis Num])=-1,0,[Site Visit Vis Num]))

Highlighted
Partner
Partner

From one of your first screenshots with the listbox where you have data you use the dimension day with a dateformat "20/11/2014", where in your later screenshots you have date as dimension with format "20/11/14". My guess is that you have data coming from two tables not correctly coupled on date because of different date formats, make sure the date format is the same in your load script.

Highlighted
Creator
Creator

Actually this date I have converted in dimension columns by using date function.

Highlighted
Creator
Creator

Already I used it, but no use.

Highlighted
Not applicable

The best bet will be to create a copy of your QVW file and remove everything except one chart. Everyone out here are just assuming scenarios and sharing their feedback.

it would not be of much effort to you.

Highlighted
Creator III
Creator III

from your screen shot above just try this expression

SUM({<[Channel Count]={'PPC'}>}[Site Visit Vis Num])

Highlighted
Creator
Creator

I am doing in remote server where this problem occurs. But it is working in my personal edition.

Pls find the attachment which is available in my local machine. I am not able to copy from remote server to my local.

Highlighted
Not applicable

This attachment is not having the data for Site Visit Vis Num , so it is of no use here. You have received almost all the possible ways out for this issue.

Give one last try, use double quotes "" inside set analysis. If it does not work, then try the above solutions on your collegues machine with same data model or create a new QVW or delete current chart and create a new one.

Hope this is helpful

Thanks,

Singh

Highlighted
Contributor II
Contributor II

One more idea. Could you check pls are the fields [Campaign Channel] and [Site Visit Vis Num] located in ONE table? OR is there a link between two tables which have these fields(in case of two tables of course)?

Make a table scheme screenshot like this one(CTRL+T):

1.png

Highlighted

Hi Kumar, you can create a table box with only those two fields. Then check if both fields have values in the same row.


In a screenshot above when you show the 'Campaign Channel' list box it's called 'Count Channel', why show this name? there is another field called count channel or it's just a customized caption?