Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

marcorizzo
New Contributor III

Problem with data fields

Hi.

I'm reading 2 different excel files (w and v).

I've got 2 fields data that I've renamed "data".

I tried to use this script to be able to filter by data. The v-values start from 01-2013 while the w-values start from 02-2013.

tab0:

LOAD Data as data,

     Ora as orav,

     Giorno as giornov,

     [Telefono cliente] as [telefono cliente v],

     Secondi as secondiv,

     [Secondi Completo] as [Secondi Completov],

     Interno,

     [Numero Interno] as  [Numero Interno v],

     [Ragione sociale] as [Ragione Sociale v],

     Provincia as provinciav,

     Stato as statov,

     Flusso as flussov,

     Tipo as tipov,

     Categoria as categoriav,

     Macrocategoria as macrocategoriav

FROM

(txt, codepage is 1252, embedded labels, delimiter is '\t', msq);

LOAD [Partita Iva] as [Partita Iva w] ,

     [Ragione Sociale] as [Ragione Sociale w],

     Prodotto as Prodottow,

     Reparto as repartow,

     Interno,

     [Data inizio] as [Data inizio w] ,

     [Ora inizio] as [Ora inizio w],

     [Ultimo aggiornamento] as data,

     [Ora ultimo aggiornamento] as [Ora ultimo aggiornamento w],

     Modalità as modalitàw,

     Tempo as tempow,

     Priorità as prioritàw,

     Stato as statow,

     [Bloccato o Extra] as [Bloccato o Extra w]

FROM

(biff, embedded labels, table is Foglio0$);

tab1:

load Distinct data,

year(data) as ANNO,

Month(data) as MESE,

Week(data) as SETTIMANA,

WeekDay(data) as GIORNOSETT,

Day(data) as GIORNOMESE,

QuarterName(data) as TRIMESTRE

resident tab0

;

.............................

It doesn't work. When I see the values available for the field data, there are only february and march.

Any suggestion ?

Thank a lot

1 Solution

Accepted Solutions
marcorizzo
New Contributor III

Re: Problem with data fields

Hi. The formi s the same in both excel files.

What can I check more ?

Da: Kaushik Solanki

Inviato: martedì 2 aprile 2013 14.40

A: MarcoRizzo

Oggetto: - Re: Problem with data fields

<http://community.qlik.com/index.jspa> QlikCommunity

Re: Problem with data fields

created by Kaushik Solanki <http://community.qlik.com/people/kaushik.solanki> in Connectivity and Data Sources - View the full discussion <http://community.qlik.com/message/328862#328862>

4 Replies

Re: Problem with data fields

HI,

     The date column coming from Export webrecall.xls is not in proper formate. Kindly change the format in excel and reload it again.

Regards,

Kaushik Solanki

 

marcorizzo
New Contributor III

Re: Problem with data fields

Hi.

Do you mean in the excel file ?

How have you understood the problem without the excel file ?

Sorry for my bad English and I'm a new user of this software.

This is what I've got.

Thanks

Re: Problem with data fields

Hi,

     Yes the data coming from Excel is not in proper form.

     The way I got is, in your application if you put Date as list box, you will find that there are two dates which is not in proper form. And if you click on that you will find that the data from Export .. excel is associated.

     So open the excel and change column type to date and see if you see all data properly.

Regards,

Kaushik Solanki

marcorizzo
New Contributor III

Re: Problem with data fields

Hi. The formi s the same in both excel files.

What can I check more ?

Da: Kaushik Solanki

Inviato: martedì 2 aprile 2013 14.40

A: MarcoRizzo

Oggetto: - Re: Problem with data fields

<http://community.qlik.com/index.jspa> QlikCommunity

Re: Problem with data fields

created by Kaushik Solanki <http://community.qlik.com/people/kaushik.solanki> in Connectivity and Data Sources - View the full discussion <http://community.qlik.com/message/328862#328862>

Community Browser