Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
MCampestrini
Valued Contributor

Problems starting Oracle SQL procedures

Hi!

I'm facing a problem when I try to call a SQL procedure.

I'm connecting to the DB via ODBC32, and when I run the app in desktop, it works; but, when I run the app via QMC I receive the following error "

17/12/2014 16:40:44: 0144        Call insere_resumo_agente_ano(1, 201411, 1802581.3799994)

17/12/2014 16:40:44:         Error: SQL##f - SqlState: S1000, ErrorCode: 1456, ErrorMsg: [Oracle][ODBC][Ora]ORA-01456: não é possível executar a operação de inserção/deleção/atualização em uma transação READ ONLY

17/12/2014 16:40:44:         ORA-06512: em "QLIKVIEW.INSERE_RESUMO_AGENTE_ANO", line 43

17/12/2014 16:40:44:         General Script Error"

And this error occurs only after one successful call.

Marcio

Márcio Rodrigo Campestrini
3 Replies
MVP
MVP

Re: Problems starting Oracle SQL procedures

try to add a commit at the end of the stor proc

Not applicable

Re: Problems starting Oracle SQL procedures

Do QMC service account has access to SQL procedure?

MCampestrini
Valued Contributor

Re: Problems starting Oracle SQL procedures

Hi everyone.

Thanks for the help.

What I've did is to define the parameter "mode is write" in the string connection and set the option "Open Databases in Read and Write mode" in script editor.

Márcio

Márcio Rodrigo Campestrini
Community Browser