Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Sokkorn
Honored Contributor

QV11 SAP Connector 5.6 Problem

Hi All,

I just install QlikView 11 and SAP connector 5.6 on Window 7 Enterprise 64 bit.

Here is my connection string

1. CUSTOM CONNECT TO "Provider=QvSAPConnector.dll;ASHOST=192.168.141.1;SYSNR=FCD;CLIENT=400;KeepCasing=1;NullDate=1;XUserId=FMNJSYRNJbaGXQBOTC;XPassword=CaSaWAJMDLMETZQGVZfB;";

2. CUSTOM CONNECT TO "Provider=QvSAPConnector.dll;ASHOST=192.168.141.1;SYSNR=FCD;CLIENT=400;KeepCasing=1;NullDate=1;XUserId=FMNJSYRNJbaGXQBOTC;XPassword=CaSaWAJMDLMETZQGVZfB;TimeOutFetch=2000;";

The first one is defaule connection string. And the second one I try to add <TimeOutFetch=2000>. Both of these is not working.

When I reload the data then I got Script Error

Custom read failed

SELECT * FROM MBEW;

Does anyone have an experience with this error? Please help to check detail on attached file for the log file.

Your reply is much appreciate .

Regards,

Sokkorn Cheav

10 Replies
Sokkorn
Honored Contributor

QV11 SAP Connector 5.6 Problem

Hi,

Can anyone help me on this?

Awaiting for your prompt response.

Regards,

Sokkorn Cheav

suniljain
Honored Contributor

QV11 SAP Connector 5.6 Problem

it receives 0 rows . I seen in  attachment. can you try to extract any other table?.

like MARA, MAKT.

Sokkorn
Honored Contributor

QV11 SAP Connector 5.6 Problem

Hi SunilKumar,

Thanks for your reply.

I try all the table that you mention, but still no record. After I click on OK button with popup message <Custom Read Failed> then I got in load script <Error:Unknown>. One more if I copy the same file to load on the other machine (QV10 SR3) then it working fine. I'm really wonder on this.

Do you have any idea?

Thanks for your reply once again.

Regards,

Sokkorn Cheav

Employee
Employee

QV11 SAP Connector 5.6 Problem

Hi,

the connectstring looks wrong, the sysnr is usually a 2-digit number. Have you tried the Test button in the Connect dialog?

Regards,

Lars Wahlstedt

Sokkorn
Honored Contributor

QV11 SAP Connector 5.6 Problem

Hi Lars Wahlstedt,

For test connection is working find for both of my script mention above.

Any idea?

Manay thank for your suggestion.

Regards,

Sokkorn Cheav

Employee
Employee

Re: QV11 SAP Connector 5.6 Problem

Hi,

Strange, since the sysnr has to be 2 digits, looks like you have mixed it up with the system id which is 3 characters.

Regards,

Lars Wahlstedt

Architect - Connectivity

Direct: +46 10 209 7750

Mobile: +46 733 327165

Fax: +46 10 209 7501

Email: Lars.Wahlstedt@qlik.com

QlikTech International AB

Scheelevägen 24-26

SE-22363 Lund

qlik.com<http://www.qlik.com/>

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

Sokkorn
Honored Contributor

Re: QV11 SAP Connector 5.6 Problem

Hi Lars Wahlstedt,

Thanks for your reply. Maybe wrong QV connector and transport in SAP. So please advise me which QV connector version and transport that suitable for SAP ECC 6.0

Regards,

Sokkorn Cheav

Not applicable

QV11 SAP Connector 5.6 Problem

Hello,

In order to test completness of SAPConnector on SAP, connect to SAP and try the transaction

/n/QTQVC/SQL

-> select * from t000 -> open stream -> fetch stream. A result -> install complete

Concerning the connection screen, I agree that it looks wrong. SYSNR is a 2 digits number. Another example just below :

CUSTOM CONNECT TO "Provider=QvSAPConnector.dll;ASHOST=10.1.122.46;SYSNR=00;CLIENT=010;XUserId=TfZSUYRNJbaMXUVMXbDA;XPassword=aLFUUSBPBbYeWWBOULYWJ;";

Use the wizard and the test function to build the connection string

Regards

Philippe

Not applicable

Re: QV11 SAP Connector 5.6 Problem

Hi,

Does SAP connector 5.6 available free of cost?

Please provide the link to download it.

Community Browser