Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
pgamarra
New Contributor

QV11_SR2 loads incomplete data from SQL Server table

Hi all. I have a table in a SQL Server DB, with 7 million of rows. When my QV App loads this table, I notice that some values from a specific field (type: char(8)) are incomplete. I mean, e.g. these values from my SQL table: '00226303', '00835842', '01004089', appears in QV as '226303', '0835842', '1004089'.

I'm worry about this, because there are more cases and I use that field for identification purposes.

I use QlikView 11.00.11414.0 SR2 64-bit

Does exist any patch to fix this issue? I'll be appreciated for any help.

Thanks in advance.

GBY.

Percy

1 Solution

Accepted Solutions

Re: QV11_SR2 loads incomplete data from SQL Server table

Hi Percy,

This is not an issue. QlikView does not have data types, all values are interpreted and represented either numeric or literal, or both (dual). When you want a field to be loaded into QlikView as it comes from the database (literal), regardless its type in the source, use the Text() function:

Table:

LOAD Text(Value) AS Value; // will keep preceding zeroes

SQL SELECT Value

FROM dbo.Table;

Hope that helps.

Miguel

2 Replies

Re: QV11_SR2 loads incomplete data from SQL Server table

Hi Percy,

This is not an issue. QlikView does not have data types, all values are interpreted and represented either numeric or literal, or both (dual). When you want a field to be loaded into QlikView as it comes from the database (literal), regardless its type in the source, use the Text() function:

Table:

LOAD Text(Value) AS Value; // will keep preceding zeroes

SQL SELECT Value

FROM dbo.Table;

Hope that helps.

Miguel

pgamarra
New Contributor

Re: QV11_SR2 loads incomplete data from SQL Server table

Thanks Miguel. It works.

By the way, this is the first time that I face this issue. I've never used the text() function to load values because all data that my QV apps loaded, were complete and similar to their sources. It seems that, from now on, I have to use text() to load sensible data. 

Just in case, do you know if this issue is related to this QV version?

GBY.

Percy

Community Browser