Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Reload fails in QMC

There are lots of questions on this forum about failed reloads, usually caused by incorrect rights (either database or via section access).

However in my case that doesn't seem to be the issue.

I have this LOAD script that connects to a SQL server database. The script loads correctly in the desktop client. In QMC it loads the first couple of tables and than stops with a "Table not found" message. I believe this is not the primary issue but caused by the load statement before that; the log file shows that the statement before that does not return results, but throws no error either.

Below is the log result from the last succesfully completed LOAD (452949 lines fetched). After that is a SQL load where the line "2 fields found" and "... lines fetched" are missing.

2014-11-24 11_52_48-___stqlv02_apps$_Datamodel_WFM Data Layer.qvw.log - Notepad  .png

This is the same log from the qlikview desktop, notice the result is different.

2014-11-24 11_53_55-___stqlv02_apps$_Datamodel_WFM Data Layer.qvw - OK.log - Notepad  .png

The qvw contains no section access, SQL rights are correct as the previous SQL loads do return results.

Any ideas?

Tags (2)
1 Solution

Accepted Solutions
bwisenosimenkg
Not applicable

Re: Reload fails in QMC

The service user might not have the rights to read from the SQL server.

Try to put an exit script underneath the SQL Select and see if the table exists in the model.

7 Replies
vinay_hg
Not applicable

Re: Reload fails in QMC

u r renaming filed as id_loannumber_application, leningnumber correct but in the dim_loannumber_application table or concatinating resident Aanvraag table already with this namefileds are there.( i mean already fileds with  id_loannumber_application, leningnumber names exists in table) please rename the both fileds and check once still same error then there is somsthing wrong in concatenating. please check the first scenario and confirm. i guess ur issue will be caught hold in first method.

thomaswrieck
Not applicable

Re: Reload fails in QMC

maybe try a NoConncatenate after "LoanNumberApplication"

LoanNumberApplication:

NoConncatenate

LOAD

.

.

.

Not applicable

Re: Reload fails in QMC

Thanks Vinaykumar. I do rename the fields to id_loannumber_application and Leningnummer.

Since I want to concatenate two tables I use the same name in both statements so QV will append 2nd table to to the first.

This works correctly in the QV desktop

Not applicable

Re: Reload fails in QMC

Hi Thomas

I tried you suggestion but to no avail. The result is the same: correct reload in QV desktop, fail in QMC

Not applicable

Re: Reload fails in QMC

Are the execution rights the same for you and the server login?  If not your sql may execute differently when run by the admin user

bwisenosimenkg
Not applicable

Re: Reload fails in QMC

The service user might not have the rights to read from the SQL server.

Try to put an exit script underneath the SQL Select and see if the table exists in the model.

Not applicable

Re: Reload fails in QMC

That's it! The service user did not have read rights on this one specific table.

Thanks for all the help!