Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

SAP Connector issue

Dear All,

I am facing a problem related to SAP Connector.

I am explaining you the whole scenario regarding the problem which I am
facing while connecting with SAP using SAP Connector.

The scenario is as follows:

Previously, SAP Connector was connecting through SAP using Server IP Address.

But now, client has created a intermediate routing between SAP server and
Main Server i.e. RFC routing.

RFC Routing create a file i.e. "SAPRFC.ini".

So, Server IP is changed to server host name and group name. And these
host name and group name are defined in "SAPRFC.ini" file.

Server Host Name : erpprd
Server Group Name : erprfc

Now, we are not able to connect to server and also SAP Connector is not
able to reading the "SAPRFC.ini." file.

As a result, we are not able to connect qlikview with SAP through SAP
Connector..

Kindly provide me appropriate solution.

Tags (1)
1 Solution

Accepted Solutions
suniljain
Honored Contributor

SAP Connector issue

Can you post SAP Connector Log File Details?.

I will help me to find exact root of this issue.

7 Replies
suniljain
Honored Contributor

SAP Connector issue

Can you post SAP Connector Log File Details?.

I will help me to find exact root of this issue.

suniljain
Honored Contributor

SAP Connector issue

Dear ankur,

In case of RFC Routing, you have tranport file in server whose role is message server.

you can check it through SM51.

and after that you have to assign role to user in that server.

Regards

Sunil

Not applicable

SAP Connector issue

Hi Sunil,

The SAP connector log is not being generated. I am trying to reinstall the SAP connector on the QV server and then see if it works. The main isue as I understood is t he transported files are not getting linked with SAP connector.

suniljain
Honored Contributor

SAP Connector issue

Pls tranport in message server and assign QTQVCACCESS role I am sure your issue will be resolved.

suniljain
Honored Contributor

SAP Connector issue

Dear Ankur,

It is solved or what ?.

Not applicable

SAP Connector issue

Hi Sunil,

The issue has been resolved. We installed the latest version of SAP connector in our server, this allows us to put the Host name and Group name. Then get the associated transport files installed on the SAP server.

1. E6DK900099 (Data extraction)
2. E6DK900086 (User profile)

The transports must be installed in the above sequence.

It worked for me. Thanks for you help in this matter.

Regards,

Ankur

suniljain
Honored Contributor

SAP Connector issue

its good news.

In Messege server you trasport file or anytihng else ?.

Community Browser