Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

vchuprina
New Contributor II

Script doesn't work through publisher

Hi everyone,

My script works correctly when I reload it manually, but when I try reload it by publisher it doens't work, see logs below.

In logs I don't see any issues, script stop work by itself.

How can i fix such kind of issue?

Thanks,

Vitalii

5/9/2017 10:28:36 AM: 0010  SET ThousandSep=','

5/9/2017 10:28:36 AM: 0011  SET DecimalSep='.'

5/9/2017 10:28:36 AM: 0012  SET MoneyThousandSep=','

5/9/2017 10:28:36 AM: 0013  SET MoneyDecimalSep='.'

5/9/2017 10:28:36 AM: 0014  SET MoneyFormat='$#,##0.00;($#,##0.00)'

5/9/2017 10:28:36 AM: 0015  SET TimeFormat='h:mm:ss TT'

5/9/2017 10:28:36 AM: 0016  SET DateFormat='M/D/YYYY'

5/9/2017 10:28:36 AM: 0017  SET TimestampFormat='M/D/YYYY h:mm:ss[.fff] TT'

5/9/2017 10:28:36 AM: 0018  SET MonthNames='Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec'

5/9/2017 10:28:36 AM: 0019  SET DayNames='Mon;Tue;Wed;Thu;Fri;Sat;Sun'

5/9/2017 10:28:36 AM: 0022  LET vDirPath = '\\eu-be-qvs07\E$\Qlikview\BI\M3\live\IT\Customizations'

5/9/2017 10:28:36 AM: 0023  LET vSubFolder = '\\eu-be-qvs07\E$\Qlikview\BI\M3\live\IT\IT04'

5/9/2017 10:28:36 AM: 0027  EXECUTE cmd.exe /C xcopy/s/Y "\\us-**\Data_PRD\Customer" "\\us-**-2\E$\Qlikview\BI\Customers"

5/9/2017 10:28:36 AM:       Running an execute command

5/9/2017 10:29:45 AM: 0030  FOR each Dir in dirlist (Root&'\*')

5/9/2017 10:29:46 AM:      Execution finished.

2 Replies

Re: Script doesn't work through publisher

Could be issue with Path may be set in Development env. like

vDirPath = '..\..\eu-be-qvs07\E$\Qlikview\BI\M3\live\IT\Customizations'

Re: Script doesn't work through publisher

check whether your service account is able to access all the paths mentioned ...

Community Browser