Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Scripting error

What does it mean? Help me, please

I have scripting error at the start.

D_temp:

load

date($(mnD)+Rowno()-1) as Д

AutoGenerate 1+$(mxD)-$(mnD);

WD_s:

LOAD

  Date(Д) as %RoutDate,

  Date(Д) as Day_,

  Week (Date(Д)) as WeekNum,

  MonthName(Date(Д)) as Month_,

  Year(Date(Д)) as Year_,

  WeekDay(Д)+1 as DayOfWeek_

Resident D_temp;

DROP Tables D_temp;

left join (WD_s) load DayOfWeek_, DayOfWeekName inline

[DayOfWeekName, DayOfWeek_

Пн,1

Вт,2

Ср,3

Чт,4

Пт,5

Сб,6

Вс,7 ];

8 Replies
vishsaggi
Esteemed Contributor III

Re: Scripting error

Can you share that error screen shot or run your script in debug mode and see where exactly it is failing? Capture.PNG

Re: Scripting error

May be change it to bold one. Here, I assume mnD, mxD are variables and meantime, can you confirm the red bold whether what those values?

D_temp:

load

date($(mnD)+Iterno()-1) as Д

AutoGenerate 1

$(mnD) + IterNo()-1 <= $(mxD);

WD_s:

LOAD

  Date(Д) as %RoutDate,

  Date(Д) as Day_,

  Week (Date(Д)) as WeekNum,

  MonthName(Date(Д)) as Month_,

  Year(Date(Д)) as Year_,

  WeekDay(Д)+1 as DayOfWeek_

Resident D_temp;

DROP Tables D_temp;

left join (WD_s) load DayOfWeek_, DayOfWeekName inline

[DayOfWeekName, DayOfWeek_

Пн,1

Вт,2

Ср,3

Чт,4

Пт,5

Сб,6

Вс,7 ];

//May be this

left join(WD_s)

load * inline [

DayOfWeekName, DayOfWeek_

Пн,1

Вт,2

Ср,3

Чт,4

Пт,5

Сб,6

Вс,7 ];

Not applicable

Re: Scripting error

!2.png

Not applicable

Re: Scripting error

Безымянный.png

Re: Scripting error

May be try date+Rowno()-1 instead of date(+rowno()-1)

Not applicable

Re: Scripting error

Doesn't work. I have the same error.

Re: Scripting error

Would you share QVF File, Please?

DROP Tables D_temp; // Please change to below because here you are dropping single Table only not more than one

DROP Table D_temp;

Not applicable

Re: Scripting error

Thank you very much. It was very helpful for me.

I had some changes in CSV file (added two columns), that's why I couldn't load data.

This is my inattentionSmiley Happy


Many thanks,

Yuriy

Community Browser