Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Section Access

Hi,

I am trying to reduce the data based on the user logged in . Qvw file is not even prompting for the username and password.

Please find the below script.

User Table:

Username Password Access CID

User1 user1 user c1

User2 user2 user c2

User3 user3 user c3

User4 user4 user c4

Admin Admin Admin *

Section Access;

Load

Username, Password, Access, CID

from table1;

Section Application;

Load

Username, Password, Access, CID

from table1;

I have enabled the Initial Data reduction based on the section Access.

Strict exclusion.

I am not sure why it is not prompting for user name and password.

Tags (1)
1 Solution

Accepted Solutions
Not applicable

Section Access

I was using like this

User Table:

Username Password Access CID

So it was prompting me only the Password in section Access. it was the username Caused the problem. It should be Userid.Once i changed to userid it is working fine.

8 Replies
martin59
Valued Contributor II

Re. :Section Access

Hi,

Your fields have to be in uppercase and you have to rename them like this :

LOAD ACCESS, USERID, PASSWORD, ... FROM Table1;


In the ACCESS field, you have to enter these values : ADMIN or USER

Hope it helps you.

prieper
Honored Contributor II

Section Access

You need to observe instructions regarding use of capital letters and need to insert "STAR IS"-command.

SECTION ACCESS;
STAR IS *;
Table1:
LOAD
*
INLINE
[USERID, PASSWORD, ACCESS, CID
User1, user1, USER, c1
User2, user2, USER, c2
User3, user3, USER, c3
User4, user4, USER, c4
Admin, Admin, ADMIN, *];
SECTION APPLICATION;
Data:
NOCONCATENATE LOAD * RESIDENT Table1;


HTH
Peter

Not applicable

Section Access

Hi Peter and Martin,

Thanks for your response. Now the funniest thing is it is prompting only for the Password.

And i am not able to access the file itself.

Any way to resolve this...

prieper
Honored Contributor II

Section Access

Continue with the backup-copy .... Wink

Peter

Not applicable

Section Access

That is the disappointment because i dont have the backup.Want to know when it will prompt only the password.At what scenario

Not applicable

Section Access

Hi Peter,

I found the reason why it is prompting only the Password and i have fixed the issue.Thanks for your support

Not applicable

Section Access

Hi

can you tell me the scenario....

what is the reason it was prompted only password....

Not applicable

Section Access

I was using like this

User Table:

Username Password Access CID

So it was prompting me only the Password in section Access. it was the username Caused the problem. It should be Userid.Once i changed to userid it is working fine.

Community Browser