Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Session Access not working properly (QV11)

Hi Guys,

I encountered a weird situation wherein section access is not working properly. If I login using AA, the COUNTRY is filtered by INDIA, which supposed to see all the data. If I login using BB, COUNTRY is filtered correctly. Is this a bug or did I miss something?

Here's my code:

SECTION ACCESS;

SECURITY_TABLE:

LOAD * INLINE

       [

    ACCESS, USERID, PASSWORD, NTNAME, COUNTRY

    ADMIN , AA,  AA,     *,  *

    USER , BB,  BB,      *,  INDIA

    ]

       ;

      

SECTION APPLICATION;

LOAD * INLINE [

COUNTRY

AUSTRALIA

SINGAPORE

PHILIPPINES

INDIA

];

Thanks,

Ronald

Tags (2)
1 Reply
rajni_batra
Valued Contributor

Re: Session Access not working properly (QV11)

when we use * as above u have written it will display only values of Country you defined in inline Table,

if you want to display all the countries then u have to write then in the table,

e.g.

    ACCESS, USERID, PASSWORD, NTNAME, COUNTRY

    ADMIN , AA,  AA,     *,  INDIA

    ADMIN , AA,  AA,     *,  AUSTRALIA

     ADMIN , AA,  AA,     *,  U.S.A

    USER , BB,  BB,      *,  INDIA

   OR(IN EXCEL)

ACCESS USERID PASSWORD NTNAME COUNTRY

ADMIN      AA            AA                   *               *

USER       BB           BB                  *               INDIA

                                                                           AUSTRALIA

                                                                            U.S.A

Hope to Help !!!

Community Browser