Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

chematos
Valued Contributor II

Sharepoint connection issue

Hi, I´m using this example to try to connect with sharepoint:

" Example URLs to be used in QlikView:

http://your-sharepoint-server/site/_vti_bin/owssvr.dll?Cmd=Display&XMLDATA=1&RowLimit=0&List={B9C20FC4-4C04-4F4C-93EF-E69E11D286F2}"

I´m using this URL and is not working:

http://our-server.com/Dpto/_vti_bin/owssvr.dll?Cmd=Display&XMLDATA=1&RowLimit=0&List={XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}

If I put the URL in the browser, the xml file is downloaded, but using the same in QlikView returns a syntax error and if I use the same but without "Dpto",

http://our-server.com/_vti_bin/owssvr.dll?Cmd=Display&XMLDATA=1&RowLimit=0&List={XXXXXXXX-XXXX-XXXX-...,

it returns to me " The object was not found"

This is the URL looks like when I´m seeing the lists:

https://sharepoint-server.com/Dpto/Lists/SOMETHING/Allitemsg.aspx

Thank you for your help.

Regards, Chema.

1 Solution

Accepted Solutions
chematos
Valued Contributor II

Re: Sharepoint connection issue

I could get the list! I needed to use this sequence:

1.- File -> Open URL  (using the same URL, QV bring me the login page of my sharepoint)

2.- Logging in sharepoint

3.- Follow the steps in the script normally

So my next question is:

Is there a way to use the login embedded in the URL to use only the script section and not to do the first two steps??

16 Replies
itberatung24
New Contributor III

Re: Sharepoint connection issue

Perhaps this helps:

http://community.qlik.com/message/242749#242749

Regards

Norbert

chematos
Valued Contributor II

Re: Sharepoint connection issue

I have already seen that thread, I´m following all steps from this doc:

http://community.qlik.com/docs/DOC-1308

Employee
Employee

Re: Sharepoint connection issue

We have had reports of something similar happening in the early version of QlikView 10 SR5 but in the updated SR5 it is working (build 10.00.9519).
So possibly the problem is version related.

chematos
Valued Contributor II

Re: Sharepoint connection issue

Thank's mls, we will check it out.

chematos
Valued Contributor II

Re: Sharepoint connection issue

We are using SR1 11.0.11282.0

I have no clues what´s happening and what to do

Employee
Employee

Re: Sharepoint connection issue

I have done a quick test in your version and I too get a syntax error when importing from a Sharepoint list. The same list works in version 10 SR5, so it would seem to be a bug in v11 SR1.

You may be able to workaround it by extracting the list in 10SR5 and saving the result as a QVD which you can then read into v11.

I would suggest reporting this as a support case so that it can be looked into a bit more.

chematos
Valued Contributor II

Re: Sharepoint connection issue

Thank you Magnus, it would be to know what versions have problems with this and what versions didn´t.

Regards

chematos
Valued Contributor II

Re: Sharepoint connection issue

The problem would be with Desktop or Server??

I've tried changing the Desktop to SR5 Qv 10 as you said and now I´m getting this error message: "The download failed"

In v11 returns: incorrect syntax was used in a comment

Employee
Employee

Re: Sharepoint connection issue

I tried it in both Desktop & Server which showed the same behavior

In my tests it worked with 10 SR5, and the new error sounds more like a failure connecting to Sharepoint, can you double check if you can download the list from a browser on the same machine as you are getting this issue?

Community Browser