Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
agaetisproject
New Contributor III

Store fields leads to Unknown error

I try to export a sub-set of a table from my load script by using the Store function.

It works very well as soon as the number of fields is limited. More precisely, when I export less than 13 fields.

As soon as I want to list more fields, I get an export error.

Store

Field01,

Field02,

...

Field14

From TableName into filename.txt;

Have you ever noticed that on your end?

Corollary, is it possible to extract all fields using * and specify the fields I do not want to appear in the extract.

Thanks in advance for you help!

Regards,

5 Replies

Re: Store fields leads to Unknown error

Have you tried this:

Store TableName into filename.txt;

agaetisproject
New Contributor III

Re: Store fields leads to Unknown error

This will export all fields Sunny. I only want to export a subset of the fields.

My issue is that the syntax is crashing if the number of fields I specify is above 13.

That should not the the case so I suspect a bug there.

Re: Store fields leads to Unknown error

What if you create a resident with only those fields which are needed and then store it?

NewTable:

LOAD Field1,

          Field2,

          ...

Resident TableAbove;

STORE NewTable into......

Re: Store fields leads to Unknown error

can you provide a sample application to test with?

thanks

regards

Marco

Re: Store fields leads to Unknown error

For me it worked fine with:

t:

load * inline [

F1    F2    F3    F4    F5    F6    F7    F8    F9    F10    F11    F12    F13    F14    F15

1    2    3    4    5    6    7    8    9    10    11    12    13    14    15

] (txt, delimiter is '\t');

store F1,F2,F3,F4,F5,F6,F7,F8,F9,F10,F11,F12,F13,F14,F15 from t into testtest.txt (txt);

therefore I think that your problem is different to the number of fields - maybe it's missing the fileformat (bolded above) or something within the data (any kind of special chars like an eof which breaks the process) or something similar. Which release do you use (mine is QV 11 SR12)?

- Marcus

Community Browser