Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
Announcement: Certain actions are currently causing a Page Not Found error. This is a known issue and we are working with the platform vendor to investigate and resolve it.
Highlighted
Not applicable

Syntax error, missing/misplaced FROM error

Trying to create a qvd from a .dat file.

I am using a template that has worked before, and changed the file names and  field names to the ones I need for this project.

However, I get the error.

Any help is appreciated

part1.pngpart2.png

1 Solution

Accepted Solutions
vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

Can you use quotes around those variables like:

Data1 AS '$(vName)',

Date2 AS '$(vName)',

.....

Can you check this ?

20 Replies
vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

May be try running the script removing semicolon ; near then statement.

IF ........ then

.........

........

ENDIF

And can you try running this in Debug Mode and see where it is throwing error?

Not applicable

Re: Syntax error, missing/misplaced FROM error

No, that didn't fix the issue.

In debug mode, the reload stops right after the 4th "Let vName4 = FieldValue('Name4',1);"

vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

Can you comment the 4th LET and run and check?

Not applicable

Re: Syntax error, missing/misplaced FROM error

Commenting out the fourth Let doesn't help.

The debugger actually stops at the line that says Fact2:

but the vName's are highlighted red when the debugger goes through them

vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

Can you use quotes around those variables like:

Data1 AS '$(vName)',

Date2 AS '$(vName)',

.....

Can you check this ?

Not applicable

Re: Syntax error, missing/misplaced FROM error

It managed to reload, but now there are no available fields...

vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

What you mean, nothing loaded? Did you debug? Is that your full script?

Not applicable

Re: Syntax error, missing/misplaced FROM error

Yes. I reloaded it and it worked, but I don't think that is the correct way to fix this issue.

After it reloaded, there were no fields. Yes that is my full script. I did debug, and it got caught right after Let vName4 and when it got to Fact2 it stopped. After putting quotes around them like you said, it reloaded, but no fields were loaded, it was just all blank.

vishsaggi
Esteemed Contributor III

Re: Syntax error, missing/misplaced FROM error

Hmm Strange. I am not sure what is happening? Can you reload only the data until LET commands and see if those variables holding any data using Ctrl+Alt+V and check the variable values?