Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Table to not be affected by some fields

Hey guys,

I have a straight table, and I have a field that i want to click on that and this table doesn't not get affected by using this field. How can I do that??

1 Solution

Accepted Solutions
mov
Esteemed Contributor III

Re: Table to not be affected by some fields

Sorry, typo:

=only({<"this field"=>} TextField)


8 Replies
mov
Esteemed Contributor III

Re: Table to not be affected by some fields

Julio,

I can do it by using set analysis.  In each expression of the table, make a change like this:

from

=sum(Value)

to

=sum({<"this field"=>} Value)

Re: Table to not be affected by some fields

You need a set analysis statement within your expressions - sum({1} VALUE).

- Marcus

Not applicable

Re: Table to not be affected by some fields

Whatever fields you are using in the Straight table, you can make a Data Island of that i,e a separate data table which is not linked to rest of the tables.

or another thing is,using macro, on selecting a field, you can disable and enable a chart.(though i am not that good in macros and are not recommended)

Thanks,

Angad

Not applicable

Re: Table to not be affected by some fields

I didn't work quite fine for me, because one of the fields is text, so, i don't know why, but set analysis doesn't work fine. I managed by creating an alternate state for that specific field, and the next straight table i'll do in this state, but i still didn't like this way of solving it...

mov
Esteemed Contributor III

Re: Table to not be affected by some fields

There could be reasons for it not working, but the text should be a problem - use expression with only()

=sum({<"this field"=>} TextField)

Not applicable

Re: Table to not be affected by some fields

=({<"this field"=>} TextField)


like this? didn't work... it says "Error in the expression...

mov
Esteemed Contributor III

Re: Table to not be affected by some fields

Sorry, typo:

=only({<"this field"=>} TextField)


Not applicable

Re: Table to not be affected by some fields

aeouihaohuaohuaeohuaoha, now It worked, kkkkkkkk, thank you alot

Community Browser