Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

jacobesalas
New Contributor II

Text on axis problem

Hi all.

I am trying to get a running total % for a bar chart. But when I copy and paste the equation for the chart and just display "text on axis" it comes out as 100% but on the straight table it comes out as a percentage (see picture).  The equation for the '% $ Win' is as follows: 

RangeSum(Above(sum({<Year={$(vYearSelected)},Quoted_Status={'Win'}>}total_price), 0, RowNo()))

/RangeSum(Above(sum({<Year={$(vYearSelected)}>}total_price), 0, RowNo()))

How can I make this equation represent an accumulated total win per week divided by the accumulated total? then just have it displayed as "text on axis"

any input is appreciated.

thank you!

Chart.jpg

1 Solution

Accepted Solutions

Re: Text on axis problem

Hi Jacob, I tried to recreate your problem but seems it's working for me, I just added a condition so values don't overlap (without that condition it will show a value for each segment of the bar)

Please take a look at the attached document to check where is the difference with your document.

5 Replies

Re: Text on axis problem

Hi Jacob, I tried to recreate your problem but seems it's working for me, I just added a condition so values don't overlap (without that condition it will show a value for each segment of the bar)

Please take a look at the attached document to check where is the difference with your document.

jacobesalas
New Contributor II

Re: Text on axis problem

Thank you.

jacobesalas
New Contributor II

Re: Text on axis problem

Ruben, 

Thanks for the help earlier.  Now I am trying to add the "% # Win" in blue underneath the other text on axis but they keep stacking see picture.

How can i fix this issue?Chart.jpg

Re: Text on axis problem

Hi Jacob, mine is showing underneath the other text, maybe we are doing it differently, to recreate my steps:

- added a new expression to calculate the %#

- ascended it to the 2nd expression

- removed the bar option

- checked to show as text on axis.

Hope this helps!

jacobesalas
New Contributor II

Re: Text on axis problem

It works perfect when I do it offline,  its when i publish it on the server it gets all wacky.

there might not be a fix to this?

Community Browser