Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

martynlloyd
Contributor III

Trouble with Peek

Can anyone spot the error here? I've been staring at it for ages....

I get NULL for _StartPref

//DATA

upType,upDate,upUser,upDocument,upParm

Start,21/08/2014 10:48:37,me,mydoc,Home

Start,21/08/2014 11:13:05,me,mydoc,Tuto

Skin,21/08/2014 11:13:05,me,mydoc,Blue

//SCRIPT

UPPref:
LOAD upType,
     upDate,
     upUser,
     upDocument,
     upParm
FROM
UserPref.qvs
(txt, codepage is 1252, embedded labels, delimiter is ',', msq)
Where upUser=OSUser() AND upType='Start'
;

Let _StartPref = Peek('upParm', -1, 'UPPref');

1 Solution

Accepted Solutions

Re: Trouble with Peek

No idea then. I assume you've already checked that you're using the same case sensitive field names everywhere.


talk is cheap, supply exceeds demand
4 Replies

Re: Trouble with Peek

OSUer() returns a username with the domain too: MYDOMAIN\MyUser. Your data only includes the user name, not the prefixed domain. The result is that no data is loaded. You can check this in the Table Viewer. Your table will be empty.


talk is cheap, supply exceeds demand
martynlloyd
Contributor III

Re: Trouble with Peek

Hi, that's only because I have removed the full AD name from the posting because of security rules. UPPref definately has rows.

M.

Re: Trouble with Peek

No idea then. I assume you've already checked that you're using the same case sensitive field names everywhere.


talk is cheap, supply exceeds demand
martynlloyd
Contributor III

Re: Trouble with Peek

Thanks, was a spelling error, i forgot a v.

Community Browser