Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Where clause not working for Ms-Access datasource

Hi Team,

I want to load data from MS-Access with limiting data from a particular column i.e Team in my case. I have written below script but could not achieve it. It is throwing some error

 

Attendance1:

  Load Attendance,

Team,

Emp Name,

Designation

Select * from Attandence where Team in('ABC','AVP','PQR');

Please help me.

Thanks in Advance

Regards

Priyanka

Tags (1)
1 Solution

Accepted Solutions
jontydkpi
Not applicable

Re: Where clause not working for Ms-Access datasource

Your SQL expression looks fine, but you need a delimiters for Emp Name, semicolon after Designation, and a SQL keyword before the Select:

Load Attendance,

Team,

[Emp Name],

Designation;

SQL Select * from Attandence where Team in('ABC','AVP','PQR');

(Is the table name spelled correctly).

If you supplied more information about the error, it would allow more accurate diagnosis. "Some error" could be just about anything...

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
1 Reply
jontydkpi
Not applicable

Re: Where clause not working for Ms-Access datasource

Your SQL expression looks fine, but you need a delimiters for Emp Name, semicolon after Designation, and a SQL keyword before the Select:

Load Attendance,

Team,

[Emp Name],

Designation;

SQL Select * from Attandence where Team in('ABC','AVP','PQR');

(Is the table name spelled correctly).

If you supplied more information about the error, it would allow more accurate diagnosis. "Some error" could be just about anything...

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein