Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

Working in SQL but not while loading the data into qlikview

Hi All,

Below query works in the sql and able to fetch the data. But when i try to load the data it is giving the error message which is there below. May I know the reason for that?


select * from user_request us join menu_list menu on menu.n_menuid=us.n_menu_id where us.n_flag=3


error loading image

6 Replies
Not applicable

Working in SQL but not while loading the data into qlikview

Hi,

You can try change the sql for this. I have the same problem.


select
*
from
user_request us,
menu_list menu
where menu.n_menuid=us.n_menu_id
and us.n_flag=3


Regards.
Tonial.

Not applicable

Working in SQL but not while loading the data into qlikview

Hi Tonial,

Thanks! But it doesn't work either!

sparur
Valued Contributor II

Working in SQL but not while loading the data into qlikview

Hello,

or try to correct your sql query:

select * from user_request us join menu_list menu on menu.n_menuid=us.n_menu_id where us.n_flag='3'

Not applicable

Working in SQL but not while loading the data into qlikview


sparur wrote:
try to correct your sql query:
select * from user_request us join menu_list menu on menu.n_menuid=us.n_menu_id where us.n_flag='3'<div></div>


Tried with also but it is not working

kevinwang
New Contributor

Working in SQL but not while loading the data into qlikview

I had same issue a few days ago, it looks like you need to define your column names in your SQL.

Not applicable

Working in SQL but not while loading the data into qlikview

I had this same type of issue and after another look at the SQL statement I was using, I noticed I had more than one column defined with the same name. It does not like this. After I got rid of the duplicate column it ran fine.

Community Browser