Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

help for qv.exe /r alex.qvw

hello,everybody.I met a question .I create two qvw files,and make a bat file,and in the bat file I write in the following:

" C:\Program Files\QlikView10\qv.exe /r d:\alex1.qvw"

" C:\Program Files\QlikView10\qv.exe /r d:\alex2.qvw"

when I run the bat file with manual,it works perfectly.the two file is reload.

but when I use the Windows Schedule,It does'nt work well.and sometime it works and sometime it not works.even it works half.

and I find the reload of alex1.qvw is over,but the other is not running yet in recurrent days.and Windows Schedule is running too.

who can tell me what is happen ? And how can I deal with this question?!

thanks a lot!

Tags (1)
1 Solution

Accepted Solutions
MVP
MVP

Re: help for qv.exe /r alex.qvw

Hi,

Try changing your quoting a bit, according to this post. The parameter should be not quoted, so your .BAT file looks like

"C:\Program Files\QlikView10\qv.exe" /r "d:\alex1.qvw"

"C:\Program Files\QlikView10\qv.exe" /r "d:\alex2.qvw"

I'd add some PAUSE command, to let the first reload end, then start the second, and not having both reloading at the same time.

Hope that helps.

Miguel Angel Baeyens

BI Consultant

Comex Grupo Ibérica

2 Replies
MVP
MVP

Re: help for qv.exe /r alex.qvw

Hi,

Try changing your quoting a bit, according to this post. The parameter should be not quoted, so your .BAT file looks like

"C:\Program Files\QlikView10\qv.exe" /r "d:\alex1.qvw"

"C:\Program Files\QlikView10\qv.exe" /r "d:\alex2.qvw"

I'd add some PAUSE command, to let the first reload end, then start the second, and not having both reloading at the same time.

Hope that helps.

Miguel Angel Baeyens

BI Consultant

Comex Grupo Ibérica

Not applicable

help for qv.exe /r alex.qvw

Yes, you are right.But it doesn't answer my question.and finally,I made three bat files ,and each bat file only have one qvw file ,and the third one deal with all bat files ,It run perfectly.and thanks a lot.

Community Browser