Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

how to connect to a (Oracle) database while the database user password contains a ";" (semicolon)

Hi,

in the script, I need to connect via ODBC (btw.: OLE does not work too). The password is like this: "xy:1;z" (without the quotation mark), so the connect string ODBC CONNECT TO [dpdev;DBQ=D] (UserId is abc, Password is xyz:1;z); does not work, because of the ";" . This seems to be ok.

But quoting the password with single quotes or double quotes does not work.

Declaring a variable LET xyzPW='dfo\:1\;d'; and changing the connect strinc to "...Password is $(xyzPW)); " does not work, neither with nor without quotes or double quotes.



Do you have any ideas how to include such a password, containing a ";" into a connect phrase? It is definitelly the ";" in the password.

Thanks in advance

Volker

4 Replies
MVP
MVP

how to connect to a (Oracle) database while the database user password contains a ";" (semicolon)

Hello Volker,

Using versions 9SR1 and 9SR2, and the wizard in the load script dialog, password is encripted by default by QlikView, so the ODBC CONNECT (XUser is ..., XPassword is ...) ciphers your username and password so they are not plain text. This should work for you, as the value passed to the database is not a plain text value but a ciphered.

Not applicable

how to connect to a (Oracle) database while the database user password contains a ";" (semicolon)

sorry: wrong password, confused by so much tests: password string is each "xy:1;z".

Not applicable

how to connect to a (Oracle) database while the database user password contains a ";" (semicolon)

Hi,

I use 9SR1, and the wizard in the load script dialog. When selecting "OLE DB", it creates such a "XPassword is ...) " phrase, (but not the "XUser is .." phrase, instead it creates a "..User ID=" ..), but this does not work too. When selecting "ODBC", it generates a clear text connection string, but never a connect string containing "XPassword is ...) " . -> it still does not work.

best regards, Volker

MVP
MVP

how to connect to a (Oracle) database while the database user password contains a ";" (semicolon)

Hello Volker,

Be sure you have ticked the option "Encrypt User Connection Credentials" in the General tab in the User Preferences in QlikView (Ctrl + Att + V). That may help.

Community Browser