Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

loading problem

hi QV,

How to load data source like this with out folder path

LOAD Date,

     Year,

     Sales

FROM

Data.xlsx

(ooxml, embedded labels, table is [Dummy Sales]);

-lohi

Tags (1)
1 Solution

Accepted Solutions

Re: Re: loading problen

Untick Relative Path.....remove all script lines and load again..

Capture.PNG.png

9 Replies
ecolomer
Honored Contributor II

Re: loading problen

You can use the complet path to access file.

By the wizard you can try

Not applicable

Re: loading problen

hi , thaxks for rply

i cant understand what you are saying can plz elaborate

-lohi

Not applicable

Re: loading problen

If you save your QV Document within the same folder like your Datasource you can Skip the path.

Another way is to set your Directory in the beginning of your script.

Re: Re: loading problen

Untick Relative Path.....remove all script lines and load again..

Capture.PNG.png

Not applicable

Re: loading problen

hi patrick,

can you plz share the screen shot let me knw how plz

-lohi

Re: loading problen

Something like below

Set vPath = 'C:\Users\ABC\Desktop';

LOAD Customer,

     Sales

FROM

$(vPath)\Sales.qvd

(qvd);

2nd:

If you have

Sales.qvd and Your QlikView Application saved in same path...

i.e. C:\Users\ABC\Desktop

Then you can directly load as

LOAD Customer,

     Sales

FROM

Sales.qvd

(qvd);

ecolomer
Honored Contributor II

Re: loading problen

yes, of course.

when you select a new flat file, you must specify the path by which you access the file.

p03.png

sorry because i'm spanish and the QV are in spanish

RED = LAN

Fichero Plano = Plain File .... for EXCEL FILE

Not applicable

Re: loading problen

I am doing it like this:

SET Datasource = 'X:\Data\Qlik View\Dummy\'; //just a dummypath

//now i can load my Tables like this

dummytable:

Load

test,

test2

FROM $(Datenquelle)\dummydata.qvo (ansi, txt, delimiter is '\t', embedded labels);

Not applicable

Re: loading problen

i mispelled the last line its:

FROM $(Datasource)\dummydata.qvo (ansi, txt, delimiter is '\t', embedded labels);

Community Browser