Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

srikanthsri1
Valued Contributor

not loading all the rows from a text file

Hi,

     I have a strange problem.i have text file of 1.1 GB with no. of records- 1.5 millions while loading it into qlikview it only pulls 670k record only.

so i spilted the text file into 2 each of it with of 600 MB.with no. of  record - 750k ..while loading it into qlikview

it pull only 356 k  records..

why it so ..is there any limit for qlikview ?

5 Replies
Not applicable

Re: not loading all the rows from a text file

Check to see in your editor that it is reading the first 10 lines properly.

There's a chance that the text file doesn't have a carriage return line feed at the end of every row.

Are there empty rows in your source?

Can you identify the missing rows?

srikanthsri1
Valued Contributor

Re: not loading all the rows from a text file

thanks for your time and reply

Check to see in your editor that it is reading the first 10 lines properly.

yes, its reading properly ..because my application doesn't break while those 370k records are loaded.

There's a chance that the text file doesn't have a carriage return line feed at the end of every row.

if it is so, how to check this and how to fix this ?

Are there empty rows in your source?

no, there no empty fileds text doc is from database. we are sure about this

Can you identify the missing rows?

no missing rows and all missing data is regarded as null

Not applicable

Re: not loading all the rows from a text file

Can you pull directly from the database?

srikanthsri1
Valued Contributor

Re: not loading all the rows from a text file

ya i.e is main problem , for some reason ... we are not provided with credentails

Not applicable

Re: not loading all the rows from a text file

Hi

I have had a similar problem.

It was solved using the solution proposed here : http://community.qlik.com/message/189249#189249

Regards

Kenn