Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

"And mode" and "Always One Selected Value" settings dropped when using TFS

I am using QlikView with TFS.  The problem I'm running into is that the settings for "And mode" and "Always One Selected Value" are missing when I get a fresh copy of my project from TFS.  

I think I understand why it is happening (because the data is not stored in TFS) but I don't know what to do about it.    Right now I'm manually reapplying the settings after I load data.  Of course, that's not a workable long-term solution.

I've tried setting the properties to true via a macro after loading data, but that does not change the behavior of the listboxes.  Should I be able to make this change to the listboxes via a macro?      Is there some other workaround I should be considering?

UPDATE:  

I figured out what I was doing wrong in the macro, so I can now update the IsAnd and OneAndOnlyOne properties via a macro after getting the project from TFS and reloading data. 

I also found a workaround that doesn't involve macros.  If you:

  1. Get a fresh copy of the project from TFS
  2. Reload data
  3. Undo pending changes
  4. Save and reopen


Then the And Mode and Always One Selected Value settings are intact.   But using this workaround I'm now losing other settings.  Specifically, I'm losing many of the date and number presentation formats set at the document level. 

I'm starting to wonder if using TFS for source control is worth the trouble.  Are people using it out there successfully? 

Thanks!

Denise

Message was edited by: dnise011

Tags (2)
1 Reply
Luminary
Luminary

Re: "And mode" and "Always One Selected Value" settings dropped when using TFS

I also found this blog, which discribes a couple of workarounds to the problem:

http://qlikviewmaven.blogspot.de/2013/01/always-one-selected-value-really.html

Community Browser