Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

script running block when creating Sync

I have 3 different excel tables (more or less 350.000 rows for each table).

When I upload 3/4 of the rows from all the tables (the filter excludes some markets) all the procedure lasts about 20 minutes (upload of the data and creation of the Sync tables.

When I upload all the data the procedure stops always at a specific Sync tables:

  • the usage of memory is fixed with no changes
  • qlik seems to be active but after hours and hours the procedure is always at the same step

Someone can help?

Thanks

Andrea

1 Solution

Accepted Solutions
tresesco
Not applicable

Re: script running block when creating Sync

This could be because your excel tables have many fields in common. This creates synthetic keys and if the number of fields in synthetic keys is too much, the problem is expected. Try to concatenate them all and reload like:

Load * From excel1path;

Concatenate

Load * From excel2path;

Concatenate

Load * From excel3path;

Concatenate

Load * From excel4path;

2 Replies
tresesco
Not applicable

Re: script running block when creating Sync

This could be because your excel tables have many fields in common. This creates synthetic keys and if the number of fields in synthetic keys is too much, the problem is expected. Try to concatenate them all and reload like:

Load * From excel1path;

Concatenate

Load * From excel2path;

Concatenate

Load * From excel3path;

Concatenate

Load * From excel4path;

Not applicable

Re: script running block when creating Sync

OK thanks.

it seems to work