Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

davide_pavan
New Contributor III

scripting engine don't work

I cannot open the module to write a macro in Qlikview, when I press Ctrl+m or 'edit the module', the sheet is doing something like "flashing"

Instead in the old Qlikview documents with a code already write i can't execute the routine because the scripting engine seems not recognize the code (see attached image)

Module.PNG

Please can you help me?

1 Solution

Accepted Solutions
davide_pavan
New Contributor III

Re: scripting engine don't work

After several attempts and some research on the net, I solved by downloading a small tool MC Afee, for the total of his AntiVirus software removal: MCPR

16 Replies
MVP
MVP

Re: scripting engine don't work

Try

     MsgBox("Hello")

MVP & Luminary
MVP & Luminary

Re: scripting engine don't work

What happens when you press the "Check" button?

-Rob

http://masterssummit.com

http://qlikviewcookbook.com

davide_pavan
New Contributor III

Re: scripting engine don't work

After "Check" button the script text highlighted in this way

Module2.PNG

trdandamudi
Honored Contributor II

Re: scripting engine don't work

Please follow the below link and you should be able to resolve your issue. Hope this helps....

Unable to open "Edit Module" window

MVP & Luminary
MVP & Luminary

Re: scripting engine don't work

Can you upload the QVW?

davide_pavan
New Contributor III

Re: scripting engine don't work

Unfortunately this is not my case. If the document has a script i can edit the module but i can't execute the code

Thank you

davide_pavan
New Contributor III

Re: scripting engine don't work

Thanks Rob, by the way this issue came few days ago after a windows update (and also after i tried to launch ScriptRepository_V1.6.qvw)

see the update:

winupdate.PNG

davide_pavan
New Contributor III

Re: scripting engine don't work

See attached qvw

davide_pavan
New Contributor III

Re: scripting engine don't work

I also unistall and reinstall Qlikview 11.2 sr12

see also Module can not be opened‌, is probably the same issue