Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Not applicable

table not found

In the following request (of which I have created more than 100 like it) I am getting a Table Not Found error.

I cannot understand this due to having done so many others without issue and not getting the error.  My understanding is that the table gets created by this very code.  I have however created a blank qvd file, to see if this works, it didnt.

Any ideas?

// Load Purchase Orders



PurchOrders:

LOAD

PURCHID as [POrder_PURCHID],

PURCHNAME as [POrder_PURCHNAME],

ORDERACCOUNT as [POrder_ORDERACCOUNT],

 
WINDOWSID as [POrder_WINDOWSID];
    

SQL SELECT

    PURCHID,

    PURCHNAME,

    ORDERACCOUNT,

    WINDOWSID
       

FROM SELSQLAX.DynAxLive.dbo.PURCHTABLE;


store PurchOrders into \\sel-app-03\QlikView\Synseal\data\PurchOrders.qvd;

Drop Table PurchOrders;

Tags (1)
1 Solution

Accepted Solutions
Not applicable

Re: table not found

Thanks for your ideas troups.  I have just copied and pasted this and dumped it into a new file and it worked straight away.

Bizarre.  Maybe a bug.  Who knows.

3 Replies
Not applicable

Re: table not found

Have you tried this SQL sentence from Managemet Studio (with the same user)? This error usually occurs when there is no records in the table.

JG

Not applicable

Re: table not found

try this

PurchOrders:

LOAD

PURCHID as [POrder_PURCHID],

PURCHNAME as [POrder_PURCHNAME],

ORDERACCOUNT as [POrder_ORDERACCOUNT],

 
WINDOWSID as [POrder_WINDOWSID];
    

SQL SELECT

    PURCHID,

    PURCHNAME,

    ORDERACCOUNT,

    WINDOWSID
       

FROM SELSQLAX.DynAxLive.dbo.PURCHTABLE;


store PurchOrders into D:\PurchOrders.qvd;

Drop Table PurchOrders;

Not applicable

Re: table not found

Thanks for your ideas troups.  I have just copied and pasted this and dumped it into a new file and it worked straight away.

Bizarre.  Maybe a bug.  Who knows.

Community Browser